OAuth App Authorization Problems w/Facebook and Google

We’re using OAuth to allow users to authorize our Zoom app. After redirecting to https://zoom.us/oauth/signin?_rnd=1568140018605&client_id=JdycgBLETAKKEDIiz3eTjw&redirect_uri=https%3A%2F%2Fzaas-dev.zmc.com%2F%40zimbra%2Fservice%2Fextension%2Foauth2%2Fauthenticate%2Fzoom&response_type=code&state=/zoomAuthCompleted;noop&scope=user:read%20meeting:write%20webinar:write
I can sign in with my Zoom.us credentials, and everything works fine.

However, if I try to sign in with Google, I end up at https://zoom.us/signin, and if I try to login from that page with my Zoom.us credentials, it just reloads the page without any indication of an error.

Similar behavior when attempting to sign in with Facebook.

Our app is in dev mode, so I wouldn’t expect the Google or Facebook accounts to be able to authorize it, but the user experience is confusing.

Hi @ron.straight,

Thanks for reaching out. Can you provide us your appID and redirect url that you’re using?

Thanks

Hey, @Michael_Purnell.

AppID: JdycgBLETAKKEDIiz3eTjw
Redirect URL: https://zaas-dev.zmc.com/@zimbra/service/extension/oauth2/authenticate/zoom&response_type=code&state=/zoomAuthCompleted;noop&scope=user:read+meeting:write+webinar:write

The zaas-dev.zmc.com domain points to localhost in my hosts file.

Like I said, the process works fine for my Zoom.us credentials. It’s only a problem when trying to sign on with one of the alternatives such as Google or Facebook. I assume those wouldn’t have access to the app since it’s in dev mode and only accessible by me, but in that case I’d expect to get the authorization screen error and not redirected to signin.

-Ron

Hey @ron.straight,

It seems like your redirect URL is malformed which could be the issue. You also do not need to include the scopes and response_type in the url.

I tested with the following redirect url and it worked,

https://zaas-dev.zmc.com/@zimbra/service/extension/oauth2/authenticate/zoom?state=zoomAuthCompleted

50%20AM

Let me know if this helps!

Thanks,
Tommy

1 Like

Hi, @tommy.

Whoops, Sorry. I was parsing the URL wrong. The actual redirect_uri is what was in the original URL I posted:

https://zaas-dev.zmc.com/@zimbra/service/extension/oauth2/authenticate/zoom

Hey @ron.straight,

No worries, thanks for posting it again! After testing with that url, it is working as expected. See video:

Can you confirm you are following the steps in the video. If it is still not working please provide steps to reproduce and if possible a video of what is happening.

Thanks,
Tommy