OAuth not redirecting after authorize


#1

I’m working with your OAuth beta. After I hit Authorize on your authorization screen I don’t get redirected to my redirect_uri. Instead, it just takes me back to https://zoom.us. Here’s how I’m calling your API

https://zoom.us/oauth/authorize?client\_id=\<MyCorrectClientId\>&redirect\_uri=http://localhost:8080/api/integration/callback&state={"integrationId":"AWBY1yNLpX0nO3BusKCU","userId":"AWBY0v3kpX0nO3BusKB4","nonce":"5708aecc-53ea-452f-aaec-147491bcc206"}&response\_type=code'

That gets me to your authorization screen, but the URL there is 

https://zoom.us/signin?\_rnd=1513380098514

That doesn’t look right. I’ve worked with five other OAuth APIs and in each case the URL of the authorization screen includes the redirect URI. For instance, here’s the URL of join.me’s authorization screen:

https://secure.join.me/API/Public/RequestPermission.aspx?&client\_id=\<MyJoinMeClienId\>&redirect\_uri=http%3A%2F%2Flocalhost%3A8080%2Fapi%2Fintegration%2Fcallback&state={%22integrationId%22:%22AWBY-9s1pX0nO3BusKC2%22,%22userId%22:%22AWBY0v3kpX0nO3BusKB4%22,%22nonce%22:%22c8b27efc-eca2-4ca5-a4bf-282669214435%22}&scope=scheduler%20user\_info%20start\_meeting&response\_type=code&request\_id=364ebd38-c0a7-4429-a6aa-e381a547a7a5&

I’ll be happy to provide my client ID, here or via email. My application name is Olono.

 

Thanks for your help.

 


#2

Hi Philip,

I think the issue lies with your redirect uri http://localhost:8080 - this is a known bug and being looked into. 

try 127.0.0.1 or setting up a url in your host file


#3

Joshua,

I registered a new developer account with a different email address and set up different redirect URIs. Now I’m calling:

https://zoom.us/oauth/authorize?client\_id=\<newClientId\>7yw&redirect\_uri=https://4f9eeee9.ngrok.io/api/integration/callback&state={"integrationId":"AWBd0lLwpX0nO3BusKFd","userId":"AWBdyw67pX0nO3BusKE0","nonce":"2442974b-50bb-4d9d-be17-e66b66702641"}&response\_type=code

I’m getting the same result as above. That is, the authorization screen URL still shows

https://zoom.us/signin?\_rnd=1513638766804

and when I click ‘Authorize’ I don’t get redirected to my redirect_uri. Instead, it just takes me back to https://zoom.us.

 


#4

Joshua, Are you still here? Any help would be appreciated. 


#5

Hi Philip,

can you email me your details so I can test? joshua.woodward@zoom.us - need client id/secret and redirect uris registered


#6

Joshua, Thanks. I’m on my way out the door to the office Christmas party. Will get this to you first thing tomorrow.


#7

https://dev.veesm.com/admin/event/CallBack?code=12c6uLoDjA_RiZh0Sm1Sv6X2jPiOUUabw
&state=token:5bba28a66b824fecbe1f6974aad8e129-cid:74783-mid:109284-instid:1992947-sid:12603-sdid:13621$12603%7C13622$12603

 

 

Hi I am requesting above url but it is not redirecting to https://dev.veesm.com/admin/event/CallBack and it is redirecting to https://www.zoom.us/meeting 

can u tell me what is wrong in my request 

  1. If I logged in already with zoom and request to above url it is calling back correct url (https://dev.veesm.com/admin/event/CallBack )

 


#8

any luck yet ?

Facing same issue , 

When i request to 

https://zoom.us/oauth/signin?_rnd=1528757713319&client_id=lnFtgNcaQ4SbA0n5D0QaDQ&_zm_bu=https%3A%2F%2Fzoom.us%2Foauth%2Fauthorize%3Fstate%3DeUBFy1t6gLkEcRyaWbdVX00NdGRESmTW%26response_type%3Dcode%26approval_prompt%3Dauto%26client_id%3DlnFtgNcaQ4SbA0n5D0QaDQ%26redirect_uri%3Dhttp%253A%252F%252Frf-web-app.com%253A8082%252Fintegrations%252Fauth%252Findex

it redirects me to https://zoom.us/signin.

Thanks in advance.


#9

You need to use https://zoom.us/oauth/authorize as the endpoint, not signin.