Authorization problems - getting UhOh undefined page for some users

I started working with simple zoom apps and run into some problems that quite hard to understand.

First of all I created test app on my test account - one I am using right now (let’s call it profile A). After some tries I make all I want

work - OAuth, reading profile, making meeting. Good and nice
I gone to other account (let’s call it profile B) - one for main work, not for tests. I creates app on marketplace following all same

steps. Now I tried to use “install” link (app properties -> Install -> Installation URL. And that URL causes some problems.

  1. Just using it in same browser while I logged in as B works fine, but it isn’t prerequisite I can enforce
  2. Using it in other browser puts me on Authorization page, which is good and what I expected. But going through it tends to be problem
    2.1. Almost every login-password combination I tried leads me to “” (“Uh-oh your lost your way”) page.
    2.2. It goes for right and wrong password combinations. Even when I enter definitely wrong password, I getting same Uh-oh page. Not even “Your password is wrong” warning. I played with some meaningless logins and password - and lots of time puts me through authorization into same Uh-oh
    2.3. One exception is for some reason profile A. Which have nothing to do with this app at all. Using Profile A shows me, that I entered wrong password - and with right password it puts me on expected page about my unability to install this app, because it is not publishable.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth. Plan to use it on Android, but current problems are in usual browsers.

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Sign out in browser
  2. Paste app’s install link
    3a. Enter email and password
    4a. Get (“Uh-oh your lost your way”) page
    3b. Enter email and wrong password
    4b. Still get (“Uh-oh your lost your way”) page

Additional context
Fictional logins from some places like zoom ru (ttttt @ zoom ru) are being checked right.
Profile A for a month was on non-basic license, but I canceled further subscription short before month I payed for ended and one more month almost passed since then. Profile B and some others I created during testing (same problems as with profile C) are basic.

@alpha900i this seems to be an issue with the OAuth / Login flow on mobile browsers. I’m not sure the issue yet, the login flow seems to not be correctly maintaining your destination when you paste the URL.

Can you share the specific browsers this is occurring in? Android Chrome?

I used both desktop browsers - Chrome, Chrome incognito, Firefox - and mobile - Chrome and standard noname browser from API 19 AVD image.
Main thing though - problem isn’t occur anymore. It disappeared as mysteriously as it looked before. I haven’t tested it today, but in about 12 hours from my original post everything started to work fine, although I haven’t changed a thing in my apps.
So with that said, topic can probably be closed.

1 Like

Hey @alpha900i,

Strange! Happy to hear it is working now though!

Please let us know if you see the issue again.