OAuth just stopped working


#1

I’m developing an OAuth application. About 45 minutes ago something changed. Now when I hit “Authorize” on the permission screen I don’t get my callback. I just get redirected to zoom.us. Did something change on your end? I didn’t make any changes to my code. Still using the same key and secret. This happened about 11:00AM PDT today, March 15. Thanks


#2

Could you provide your clientId to me?


#3

EZfazqnWSk2kICBrZbANZw


#4

Hi Philip, thanks for providing the clientId.

As you said,  you just get redirected to zoom.us. Could you provide the screenshot of this page? Perhaps it will display some error message.

I can’t authorize your clientId because we are not on the same account.


#5


#6

Hi Philip,

   When i  tested the url with your clientid this is the error i get.  Please can you send us your cookie value for  “_zm_bu” before when you click on Authorize button? 

Thanks,

Kavitha


#7

I thought the problem might be that my ngrok failed, so I restarted ngrok and changed the redirect URI in my code and in the application registration. It didn’t help, but that’s why the URI in this cookie is different than what you have.

 

Here’s my cookie:

 

_zm_mtk_guid=37e7b7271c3ed0227a6223dd5cf65769; __qca=P0-218001270-1506355333899; optimizelyEndUserId=oeu1506355330461r0.3720954570493875; _ga=GA1.2.1089361550.1506355334; __zlcmid=iggm1QYqvLFHmh; NPS_0487a3ac_last_seen=1516644532227; _zm_lang=en-US; _zm_iplang=en-US#70.113.106.243; _gid=GA1.2.254196761.1520867903; _zm_currency=USD; _zm_mtg_options=%7B%22o1%22%3Afalse%2C%22o2%22%3A%22off%22%2C%22o3%22%3A%22off%22%2C%22o4%22%3A%22voip%22%2C%22o5%22%3Afalse%2C%22o6%22%3Afalse%2C%22o9%22%3A%22none%22%7D; _zm_launcher=1520957042584; _zm_ci=EZfazqnWSk2kICBrZbANZw; _zm_cs=""; visitor_id84442=169583404; visitor_id84442-hash=87a6bb382abc3833e738ab62629143d9e9d589bf47198de7e23cd1f5a0b2f57f6bcd77ae45be5c61eb5ca2246451c729f3a9b568; _zm_everlogin_type=3; _zm_ssid=JDNgxDTsSya6oRTZV6QbvA; _zm_kms=q4NkUpOKZfDRtHJLTjDBvccseoT-4Wsk1VAi-sG-Nx8.EgEAAAFiKyA8lAB2pwAgM2VyeE5KRytUd29NYWduam9ZcTErR25LdzdoUkRWWlQYNmZaaW9uL01PMFEySGpTNkFwbVdZUT09IDQyZTM4Q3BYVElaRmZGaXNLVklHRzB0THpEVUt6a1pW; __ar_v4=F3M46SJCENDUJNOYHODQB7%3A20180312%3A1%7CDV47DVTZ4NHJNM5BVKACVM%3A20180312%3A24%7CMEJIJ4L4HBCHXCRQUE7MXI%3A20180217%3A4%7CFMRJCWUNEFG7BEWJTI3WI3%3A20180312%3A11%7CFYTZRQUEVVGS7EWCIOE64A%3A20180314%3A20%7CMNBMU5UBV5A6DJOSTXTI32%3A20180314%3A20; _zm_o2nd=a24fc711d3a8ab6538f14722185f8d89; _zm_o2bu=https%3A%2F%2Fzoom.us%2Foauth%2Fauthorize%3Fclient_id%3DEZfazqnWSk2kICBrZbANZw%26redirect_uri%3Dhttps%3A%2F%2F5618beaf.ngrok.io%2Fapi%2Fintegration%2Fcallback%26state%3D%7B%2522integrationId%2522%3A%2522AWIl1YBoo7B6B_yiVPui%2522%2C%2522userId%2522%3A%2522AWIl0ce1o7B6B_yiVPtx%2522%2C%2522nonce%2522%3A%25226ae8fe4b-7cec-4394-bd31-7a5632c76042%2522%7D%26response_type%3Dcode; cred=51FF7B95A89FF0AE21242CA490D0BD46


#8

Here is the authorization URL that goes with that cookie

 

https://zoom.us/oauth/authorize?client_id=EZfazqnWSk2kICBrZbANZw&redirect_uri=https://5618beaf.ngrok.io/api/integration/callback&state={“integrationId”:“AWIl1YBoo7B6B_yiVPui”,“userId”:“AWIl0ce1o7B6B_yiVPtx”,“nonce”:“6ae8fe4b-7cec-4394-bd31-7a5632c76042”}&response_type=code


#9

Kavitha,

 

Looking at the screen shot in your post, the URL you used didn’t include the ‘state’ parameter. I think that’s why my code errored.

 

Philip

 


#10

Kavitha,

 

Can you give me any help with this? Do you have a feel for whether the problem is on your end or am I doing something wrong?

 

Thanks,

Philip


#11

Hi Philip,

  Please can you try encoding the state value instead of JSON value ? Like below ? 

 https://zoom.us/oauth/authorize?client_id=EZfazqnWSk2kICBrZbANZw&redirect_uri=https://5618beaf.ngrok.io/api/integration/callback&state=%7B%22integrationId%22%3A%22AWIl1YBoo7B6B_yiVPui%22%2C%22userId%22%3A%22AWIl0ce1o7B6B_yiVPtx%22%2C%22nonce%22%3A%226ae8fe4b-7cec-4394-bd31-7a5632c76042%22%7D&response_type=code

 

Thanks

Kavitha


#12

Kavitha,

 

I was working on trying your last suggestion and I’ve run into a new problem. My ngrok expired so I had to restart it. When I went to change the URI registration I got an error saying I need to login. I logged out, cleared my cookies and logged back in, but I’m still seeing the error. Clearly, I must be logged in or I would not have gotten to that page. Here’s the error I see:

 

Philip

 


#13

Hi Philip,

   This issue has been fixed now. Please can you try and update us?

 

Thanks,

Kavitha


#14

I’ve been called away on other matters. It may be a few days (or longer) before I get back to this.