OAuth2 testing in Postman

Trying to get through OAuth2 testing in Postman.

I am using the Get New Access Token page but it takes me to the “Invalid redirect url (4700)” page.

What’s wrong with this setup?

Steps to reproduce the behavior:

  1. Enter in the same info in Postman but with your own client_id and client_secret.

It is probably something simple I am not seeing. Thanks for the help!

Figured this one out.

redirect_uri goes where it says “Callback URL”, not “https://myapp.io/zoomcallback

Also, I think the redirect_uri has to be an “https” address to fix the redirection however I am not 100% sure about that.

I was able to generate a token after changing the Callback URL which is the first problem I was trying to solve here.

Hey @4everCodeNLearn,

Happy to hear you resolved your issue.

Let us know if you have additional questions!

Thanks,
Tommy

sorry I got the same error.


this is a serious error for me.
Thanks

Hi baifeng1991321,

Set Callback URL = “redirect uri”. Do not set Callback URL = “https://zoom.us/oauth/callback”.

“redirect uri” should be something like “https://www.yourdomain.com/landing_page_after_login”. The “redirect uri” is the page the user sees AFTER they have logged in successfully to Zoom.

Unfortunately I am leaving my house for a few hours so I cannot help any further right now. Good luck!

Hey @baifeng1991321, thanks for posting and using Zoom!

Make sure the callback URL matches with your callback in your Redirect URL and Whitelist URL in the Zoom Marketplace Dashboard for your app.

Thanks for your help @4everCodeNLearn!

Thanks,
Tommy

in fact, I am not sure the redirect url and whitelist url in zoom marketplace dashboard for my appl.


I changed the callback url to https://www.rac24.com
but it cause the same error.
thanks

could you help me via teamviewer?
it is very urgent.
thanks

Hey @baifeng1991321,

You can schedule a meeting with me here for further assistance:

Thanks,
Tommy

1 Like

hi. how are you?
https://marketplace.zoom.us/docs/guides/authorization/oauth/quickstart
i gonna use this in angular project.
but i don’t know how to use this.

I downloaded the source code from github and executed it on my local computer.

could you help me?
thanks and regards

and I also have one problem in account api
https://marketplace.zoom.us/docs/api-reference/zoom-api/accounts/accounts
I gonna get account list in this api,
but I cannot get it on postman.
I filled a correct access token in a form and it cause the following error.


i don’t know why this error caused.
help me.
thanks

Hey @baifeng1991321,

I am well!

It looks like your backend is not sending a response to your Angular frontend.

Which github sample are you using? Here are the docs on generating a signature serverside.

As for your request in Postman, please set the Type to Bearer not OAuth 2.0.

Thanks,
Tommy

@Tommy,

Could you help me to zoom oauth test setup in postman?
I’m getting Invalid Request URL (4700) Error.
I’m following tutorial https://marketplace.zoom.us/docs/guides/authorization/oauth/quickstart.
It would be great if you are available via team viewer.

I’m trying to setup zoom LTI with our LMS system.

Hi @deepen,

When testing within Postman, please make sure your redirect url matches the one you set within your OAuth app.

https://zoom.us/oauth/token?grant_type=authorization_code&code=2LGsWqGOg&redirect_uri=https://zoom.us

Screen Shot 2020-03-26 at 11.55.36 AM

Thanks @Michael_Purnell for responding.

I’m trying to Oauth with zoom.
First step as per doc is to get authorize user and second step is retrieve access token of that user.

I am getting difficulty in first step.

Steps I followed,

  • Create one Oauth in zoom market place
  • Set https://zoom.us url in redirect url for development and production.
  • Get client id and secret
  • Use https://zoom.us/oauth/authorize?response_type=code&client_id=<CLIENT_ID>&redirect_uri=https://zoom.us to authorize user in web browser and in postman as well.

Here, I’m getting Invalid redirect url(4700) error.

Could you help me to solve this?

I can use ngrok to build URL which can forward to localhost if you can help to setup.

Thanks.

Hey @deepen,

Make sure you have set your redirect url domain (https://zoom.us) in the whitelist section.

Thanks,
Tommy

Thanks @tommy for your response.

I did test as per your suggestion and it worked for one time only.
It’s not working after I changed redirect_uri in zoom app config and in local.
I roll backed changes. but, no luck.

What I did as,

  • Changed redirect_url to https://402f3930.ngrok.io/zoom-integration/ in zoom app and redirect_url in authentication url.
  • Whitelisted https://zoom.us.

Hey @deepen,

What is the error after it worked?

Please provide steps to reproduce the issue, or a video of the issue.

Thanks,
Tommy