onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0

using the pro account, getting error onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0

Android SDK strong text

Hi libin,

Thanks for using Zoom SDK. The error code indicates that invalid arguments are passed to initialize the SDK. Is this reproducible with our demo app? Could you provide the steps to reproduce this with our demo app?

Thanks!

Hi Carson, I see the same issue. Steps are easy to reproduce with your demo app. Could you please tell what is going wrong in your app?

2 Likes

Hi aruna.gangji,

Thanks for the reply. Could you provide the steps to reproduce this with our demo app?

hie Im still getting the error onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0 using the JWT provided on the site under mu account , how best to resolve this please help

Hi itaizulu,

Thanks for using Zoom SDK. If your SDK credentials work when you are initializing the SDK with only the key & secret? (Not the JWT token?) If that works, then it means the JWT token itself has some issues, you may refer to the doc here to generate the JWT token: https://marketplace.zoom.us/docs/sdk/native-sdks/android/mastering-zoom-sdk/sdk-initialization

Please ensure your payload match the following requirements:

{
	"appKey": "string", // Your SDK key
	"iat": long, // access token issue timestamp
	"exp": long, // access token expire timestamp, iat + a time less than 48 hours
	"tokenExp": long // token expire timestamp, MIN:1800 seconds
}

Hope this helps. Thanks!

hello Carson , I am also facing same issue and I have followed all the steps as it is mentioned in doc then why I am facing this error onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0

Hi @kalpesh1,

Thanks for the reply and for pardon the late response. Are you using SDK key & secret or JWT token for SDK authentication? Aer you using SDK key & secret in generating the JWT token? Could you provide more information on how you get the error?

Thanks!

I am tring to run Sample from Zoom SDK android. I am facing error InitAuthSDKHelper: onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0 I/ZoomSDKExample: onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0 My JWT credentials are public interface [Info hidden]

Hi @kalpesh1,

Thanks for the info. Since this forum is publicly available, and you have shared your SDK credentials. I have removed the credentials you were sharing and please do re-generate your SDK credentials on Marketplace ASAP. I have gathered the info and will pass it to the engineering team for further investigation. Will get back to you shortly.

Thanks!

Hi, Carson, I met the same problem ,I used sdk key & secret to run the demo. (Android 8.1), Is there any solutions ?

Hi @zoomuser2020,

Thanks for using Zoom SDK. Let me contact you directly regarding this.

Hi, I have updated zoom android sdk v5.0.24437.0708 in my current project and accordingly changes done in code base. But it is showing [onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0] while initializing.

I also tried with Sample project but I met the same problem.

Please provide solution and guidance.

Thanks!

Hi @aparab,

Thanks for the reply. Are you authenticating with SDK key/secret or JWT token? Was this work before you updated the SDK?

Hi Carson,

Thanks for the reply. Yes I have authenticated with JWT token. JWT token is generated by using API key/Secret key successfully.

Previously it was working with old android SDK by using sdk api/secret key while initializing zoom sdk.

But now we have updated JWT authentication at server side also while creating meetings so we have updated zoom android sdk too in mobile app.

If you need any more details about credentials or codes steps, please let me know.

Thanks!

Hi @aparab,

Thanks for the reply. Could you share a sample of the payload that you are using for the JWT token? Based on the error code, it seems like the JWT token is invalid.

Thanks!

Hey, I’m also using the JWT Token generated on the marketplace.zoom.us. I’m trying to test the sample SDK of Zoom but I’m also getting the same error. There’s no option to use API key and other things anymore as mentioned in the docs which seems outdated now. Please provide a solution.

The problem is with the JWT token produced from the marketplace. When I tried to decode the JWT token that I got from the marketplace it shows me the following payload:
{
“aud”: null,
“iss”: “myapikeythatIdonotwanttoshare”,
“exp”: sometimestampIdonotwanttoshow,
“iat”: sometimestampIdonotwanttoshow
}

which is wrong according to the payload sample given in sample project and example project that comes with SDK:
{
“appKey”: “string”, // app key
“iat”: long, // access token issue timestamp
“exp”: long, // access token expire time
“tokenExp”: long // token expire time
}

I even tried to create a JWT token from jwt.io with correct parameters of payload that also doesn’t work. Can someone resolve this issue?

onZoomSDKInitializeResult, errorCode=1, internalErrorCode=0
same problem. Also tried marketplace jwt token with sample app. Its not working giving the same error.

The solution is to skip the JWT token and go with the SDK key and Secret which you’ll get when creating an app for SDK. Just comment out the line where JWTToken is initalized into the initializing parameters and provide the key and secret. It will work, apart from this I’ve not found any other solution and there support is not much of a help, nor their documentation. I’m stuck on something else.

            //initParams.jwtToken = SDK_JWTTOKEN;
            initParams.appKey = APP_KEY;
            initParams.appSecret = APP_SECRET;
1 Like