/past_meetings/{meetingUUID}/participants giving 404 with meeting not found

Wanting to retrieve participants for past meeting, meetingUUID = “ZLcSZ7+OS5SuKMSVSvP0bg==”

Issuing this query:
https://api.zoomgov.com/v2/past_meetings/ZLcSZ7%2BOS5SuKMSVSvP0bg/participants

404: {“code”:3001,“message”:“Meeting does not exist: ZLcSZ7 OS5SuKMSVSvP0bg.”}

Any ideas why this may be happening?

I have tried stripping off the ‘=’ character at end of the meeting UUID as well as leaving it intact. Same results.

Thanks!

Through additional testing, here are calls that have succeeded and those that have failed with 404:

200

https://api.zoomgov.com/v2/past_meetings/oicgmvO%2FRU2u%2Birs0Ol6qQ%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/QMJg%2FyH%2FTM%2BYPOeGMRQILg%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/f8L9r3iATmGaadz9l3vJQw%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/dzHZ9aHYR86f5ZlOKHZNvA%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/lv245UBrQcaxgnjOFzUQng%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/9gp7YQI9SqeweaXvhww3lg%3D%3D/participants
https://api.zoomgov.com/v2/past_meetings/zOQLXlDlSHqFuoBt6vb7aQ%3D%3D/participants

404

https://api.zoomgov.com/v2/past_meetings/mBFvAZikTWSCP2%2B0HB0FTg%3D%3D/participants
“Meeting does not exist: mBFvAZikTWSCP2 0HB0FTg==.”
https://api.zoomgov.com/v2/past_meetings/2CtoMZB2QyCfjx98L2**%2B**dVA%3D%3D/participants
“Meeting does not exist: 2CtoMZB2QyCfjx98L2 dVA==.”
https://api.zoomgov.com/v2/past_meetings/ZLcSZ7%2BOS5SuKMSVSvP0bg%3D%3D/participants
“Meeting does not exist: ZLcSZ7 OS5SuKMSVSvP0bg==.”

The pattern is that if the meetingUUID contains the ‘+’ character, the call will fail with 404. You can see that the ‘+’ is encoded with “%2B” as is common for URL encodings. However, the error message echos the meetingUUID with a space instead of ‘+’. A URL with a ‘+’ denotes a ’ ’ (space) in place of the ‘+’. Our meetingUUID was given to us from Zoom API with ‘+’ (a valid character in Base64 encoding).

2 things come to mind: either there’s some special handling I need to use for meetingUUIDs that contain ‘+’, or the call to retrieve past meeting participants is mishandling the ‘%2B’.

Any thoughts?
Thanks!

Just tried double-encoding if meetingUUID contains ‘+’ and it worked! Probably worth having someone from Zoom have a look and if this is truly needed, please update docs to indicate that. Please note that I’m using zoomgov.com and not zoom.us.

1 Like

Now that I’ve got past the 404, I’m noticing that none of the responses include any participants. They all look like this:

{

endpoint: “https://api.zoomgov.com/v2/past_meetings/QMJg%2FyH%2FTM%2BYPOeGMRQILg%3D%3D/participants”,

response_headers: [

“Set-Cookie: zm_aid=”"; Domain=.zoomgov.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT; Path=/; Secure; HttpOnly"

],

date_time: “2021-03-26 10:02:03”,

method: “GET”,

request_body: “N/A”,

response: {

page_count: 0,

page_size: 30,

total_records: 0,

next_page_token: “”,

participants: [

]

},

request_headers: [

“accept-encoding: gzip”,

“authorization: ******”,

“connection: close”,

“content-type: application/json”,

“user-agent: Go-http-client/1.1”

],

request_params: [

],

http_status: “200”

}

Hey @Paul-at-thetalake,

Glad you were able to get past the 404—you’re correct that you’ll need to double encode the URL if there is a / or +. We will work on making this clearer.

Regarding meetings that aren’t returning participants, can you share more details with us at developersupport@zoom.us, including the Meeting ID that the Meeting UUID(s) are associated with?

Thanks!
Will