Permissions - Zoom Phone has not been enabled for this account

Hi, I’m trying to access the phone logs for our company via the API. I was able to get OAuth working, but when I run my script, I get the following error:

{“code”:2031,“message”:“Zoom Phone has not been enabled for this account.”}

I think I have the permissions set as needed:


My code is as follows:

$url = $endpoint . "/phone/call_logs";
$headers = array (
    "Accept: application/json",
    "Content-Type: application/json",
    "Authorization: Bearer " . $token['Token']
);
$useragent = "KegWorks-API/1.0.0/" . phpversion();
$query = array(
    "page_size" => 10
);
$payload = json_encode($query);
print_r ($headers);

$ch = curl_init($url);
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_setopt($ch, CURLOPT_ENCODING, "");
curl_setopt($ch, CURLOPT_MAXREDIRS, 10);
curl_setopt($ch, CURLOPT_TIMEOUT, 30);
curl_setopt($ch, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
curl_setopt($ch, CURLOPT_CUSTOMREQUEST, 'GET');
curl_setopt($ch, CURLOPT_HTTPHEADER, $headers);
curl_setopt($ch, CURLOPT_USERAGENT, $useragent);
curl_setopt($ch, CURLOPT_VERBOSE, 0);
curl_setopt($ch, CURLOPT_HEADER, 0);
curl_setopt($ch, CURLOPT_POSTFIELDS, $payload );
$response = curl_exec($ch);
curl_close($ch);

Any help would be greatly appreciated.

Hi @jnichel nichel,

Thank you for reaching out to the Zoom Developer Forum. It looks like something that needs to be accommodated on our end. Please submit a ticket summarizing the issue with the link to this thread included. In that ticket, please also provide your account number.

You can submit a ticket by navigating to our Developer Support Center .

Make sure you’re signed in to submit a request.

Gianni

Thank you for the response. I created a ticket (#14864181) and after 6 days of back and forth, Karen basically told me to bring my problem to the Developer Forum. Her last two posts, prior to the kiss of death, was to change my grant_type to ‘account_credentials’ when requesting the token, but when I do that, I get the error:

stdClass Object
(
    [reason] => unsupported grant type
    [error] => unsupported_grant_type
)

When using ‘client_credential’ as my grant type, my token request returns this:

stdClass Object
(
    [access_token] => e**********g
    [token_type] => bearer
    [expires_in] => 3599
    [scope] => phone:master phone:read:admin phone:write:admin phone_call_control:master phone_call_control:read:admin phone_call_control:write:admin phone_call_log:master phone_call_log:read:admin phone_call_log:write:admin phone_e911:read:admin phone_recording:master phone_recording:read:admin phone_recording:write:admin phone_sms:master phone_sms:read:admin phone_sms:write:admin phone_voicemail:master phone_voicemail:read:admin phone_voicemail:write:admin user:master user:read:admin user:write:admin
)

And even tho is says that token has the proper scope needed, I still get the error that “Zoom Phone has not been enabled for this account.”

Hi @jnichel ,

I’ve connected with the support representative internally about the next steps to help you resolve as this is a back end issue and not something we can rectify on the forum. Thank you for your patience!

Gianni