Please help, i can't join as a host even though i already provided all the necessary parameters

Description
I already read all the forums about this but it can’t seem to work on me

Which Android Meeting SDK version?
Knowing the version can help us to identify your issue faster.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

Screenshots
If applicable, add screenshots to help explain your problem.

Smartphone (please complete the following information):

  • Device: [e.g. Xiaomi Poco m3 pro]
  • OS: [e.g. Android 11]

Additional context
Add any other context about the problem here.

btnStart.setOnClickListener(new View.OnClickListener() {
@Override
public void onClick(View view) {
String MeetingNumber="";
String MeetingPassword=txtPass.getText().toString();
String Username = “kol”;
String Zak = “”;
String UID = “zbsus+ZVR0CUD7nPCrL6nw==”;
joinMeeting(ZoomActivity.this,MeetingNumber,Zak,Username,UID);
}
});
}

private  void initializeZoom(Context context){
    ZoomSDK sdk = ZoomSDK.getInstance();
    ZoomSDKInitParams params = new ZoomSDKInitParams();
    params.appKey="";
    params.appSecret="";
    params.domain="zoom.us";
    params.enableLog = true;

    ZoomSDKInitializeListener listener = new ZoomSDKInitializeListener() {
        @Override
        public void onZoomSDKInitializeResult(int i, int i1) {

        }

        @Override
        public void onZoomAuthIdentityExpired() {

        }
    };
    sdk.initialize(context,listener,params);
}

private  void joinMeeting(Context context, String meetingNumber,String zak, String userName, String usID){
    int ret = -1;
    MeetingService meetingService = ZoomSDK.getInstance().getMeetingService();
    JoinMeetingOptions options = new JoinMeetingOptions();
    //JoinMeetingParams params = new JoinMeetingParams();
    //params.displayName=userName;
    //params.meetingNo =meetingNumber;
    //params.password=meetingPassword;
    //meetingService.joinMeetingWithParams(context,params,options);

    StartMeetingParamsWithoutLogin params = new StartMeetingParamsWithoutLogin();
    params.userId = usID; // Based on this id we are able to start the meeting as host
    params.userType = MeetingService.USER_TYPE_API_USER;
    params.displayName = userName;
   >  params.zoomAccessToken = zak; //getting the zoom access token from start_url
    params.meetingNo = meetingNumber; // meetingNo, getting this from create meeting api response
    ret = meetingService.startMeetingWithParams(context,params,options);
   Log.e("Start Meeting As Host", "===startMeetingWithNumber====ret=" + ret);
 }

this is my code

Hi @ajgabriel1998, thanks for using the dev forum.

First off, I had to edit out a few credentials from your post, including your developer credentials. It is extremely important that you generate a new SDK secret through the Marketplace ASAP. Your developer credentials should never be shared with anyone and should be stored securely. You should also not share a ZAK or your meeting number publicly. Doing so can compromise the security of your meeting and allow unwanted actors to get access to your meeting or personal information.

Regarding the issue you are seeing, can you please provide the error code you are seeing when you try to start the meeting and the version of the SDK you are using?

Thanks!

1 Like

hi i don’t see any error codes it’s just that when i run the app it just won’t consider me as a host even though i already passed the zak and the host_id from the api. And i don’t know where to find the sdk version

but this is color red on the logcat tho
2022-03-24 07:14:57.030 26880-26880/com.example.classroom E/Start Meeting As Host: ===startMeetingWithNumber====ret=0

so i created the meeting using my web app using zoom sdk too. Please correct me if im wrong, the “host_id” is equals to params.userId right? I tried to pass the host_id and the uuid but both doesn’t work, both doesn’t allow me to join as the host

Hi @ajgabriel1998,

Alright, thanks for the additional information. First, let’s narrow down the cause a bit before diving into specific details. You mentioned that you’re using the start URL to get the required information. Can you try passing that URL directly into the handZoomWebUrl method and let me know if you’re seeing the same behavior?

Thanks!

1 Like

i passed it directly into the method and false is the result

hand = meetingService.handZoomWebUrl(“START_URL_WITH_ZAK”);
Log.e(“Hand Zoom Web Result”, “===startMeetingWithNumber====result=” + hand);

2022-03-25 12:35:10.487 9732-9732/com.example.classroom E/Hand Zoom Web Result: ===startMeetingWithNumber====result=false

i tried entering the link on my laptop’s web browser and i was able to join as a host

Hi @ajgabriel1998,

If you’re receiving false from that method, there is probably something wrong with the URL you are using. Can you please provide the URL value you’re passing in? Be sure to replace the ZAK and meeting details with other values before posting it.

Thanks!

https://us05web.zoom.us/s/MEETING_NUMBER?zak=ZAK_VALUE

here’s my link

if there’s something wrong with the url then why can i use the link in my desktop browser and it lets me join the meeting as a host tho?

Hi @ajgabriel1998,

I was able to confirm that something appears to be wrong with the handZoomWebUrl method. We’ll investigate this separately from the issue you initially reported.

Can you please provide the SDK logs from a session where you were unable to join the meeting through the original startMeetingWithParams method? Information on how to get the SDK logs can be found here.

Thanks!

this is the logs, i don’t know what logs is the one to send so i sent the two that is the latest updated when i run the meeting. I uploaded it to mediafire because i can’t send log files here :slight_smile: i hope you can find the issue i need to finish my app :slight_smile:

Hi @ajgabriel1998,

To be clear, are both of these log files from sessions where the issue was present? There is a lot of information we need to look through when investigating logs, so please confirm before we can begin. :slightly_smiling_face:

Thanks!

yes, those 2 logs were updated when i ran my app and started the meeting :slight_smile:

Hi @ajgabriel1998,

Based on the meeting number in the logs provided, there is no meeting on our back end by that number. The SDK cannot join a meeting that doesn’t exist, so please check that you are providing a valid meeting number.

Thanks!

i am providing a valid meeting number tho, i can join the meeting because i set the join_before_host to true, the only issue is that i can’t join as a host so i can’t use the share screen function

if i can’t join as a host then is there any way to enable the share screen function to all not only to host?

Hi @ajgabriel1998,

If you are providing a valid meeting number, can you please provide the SDK logs from a session where you joined the meeting?

if i can’t join as a host then is there any way to enable the share screen function to all not only to host?

This is dependent on the meeting settings. If you are not the meeting owner and do not have screen share privileges, only the meeting owner’s account is able to modify the settings.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.