Power Automate 1001 Error

I’m trying to use Microsoft’s Power Automate platform to make API calls into Zoom using the HTTP connector. After successfully getting the flow to trigger from a Zoom webhook (routed through an Azure Function App) I’m now getting a flow failure on the HTTP request. With the same parameters I’m getting a successful response in Postman.

“code”: 1001
“message”: “User does not exist: :userId.”

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
I’m using the GET-List all recordings call.

How To Reproduce (If applicable)
You’ll need a premium license for Power Automate.
Use the HTTP Request connector and just copy the headers and parameters from Postman for this request.

Additional context
I was trying to parse out the userId and meeting_id from the original webhook, which is working fine, and then pass those values into the HTTP request. I was getting the same error, so I just ditched that effort and tried doing just the HTTP request manually entering my personal meeting ID and my user ID and I am still getting the same error. I’ve seen other similar posts with this error message and a Zoom employee asked to make sure the user exists in the account. The user is me and my user definitely exists in my account. I verified this with a list user call in Postman.

Hi @djohnson

Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
Have you tried passing /me instead of the user ID when making the request?

Hey Elisa,

I tried “me” and “/me” and neither worked. I also went and found a meeting with another user and got their user ID and the meeting ID and am still getting the same error:

“code”: 1001,
“message”: “User does not exist: :userId.”

I even tried removing the userId parameter all together, and still got the same error.

BTW, the call works in Postman, using the proper User ID and Meeting ID. It’s only when I try to reproduce the call in Power Automate that I’m getting the error.

@elisa.zoom Also just tried calling the GET-List all recordings API from within our CRMs automation platform, which allows for making API requests, and I’m still getting the same error. Here’s what I’ve got in the headers:

Authorization:Bearer (JWT Token from JWT App)
page_size: 10
mc: false
trash: false
from: 2022-02-01
to: 2022-02-01
trash_type: meeting_recordings
userId: (My actual user ID)
meeting_id: (My personal meeting ID)

“Remote service reported an error: User does not exist: :userId.”

One thing I have noticed is that the userId parameter is listed under the “Path Variables” section in Postman, but it’s not clear where or how I should be including that data in those other platforms. It seems clear that “userId” shouldn’t be a header. But I also got errors when trying to send it in the body. The error was something along the lines of, “this request cannot have a body.”

@elisa.zoom , I figured it out. I didn’t notice the curly brackets around userId in the path: https://api.zoom.us/v2/users/{userId}/recordings

I just replaced that with my actual user ID and it worked! I didn’t think about it until I typed out “path” in that last response. Anyway, it seems to be working properly now.

1 Like

Hi @djohnson
Thanks for the update, I am so glad that you were able to figure this out.
Please let me know if there is anything else I can do for you

@elisa.zoom I actually did have another question for you. It’s unrelated to Zoom, but a professional question none the less. I sent you a connection request on LinkedIn if you’ve got the time!

1 Like

@djohnson of course! happy to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.