Prevent Zoom app from taking over computer's focus

My team is always frustrated when they are on another computer window(let’s say slack typing a message) and the zoom app takes over focus. This happens when breakout rooms are open/closed mainly, but there might be other times.

Describe the solution you’d like

It would be amazing if zoom would not take over the focus of the computer

Describe alternatives you’ve considered
I’ve looked through all the zoom options and even tried to see if the macOS had a way to stop it, but found nothing

Additional context
This is on macOS Catalina.

19 Likes

Same issue in windows. Extremely frustrating.

7 Likes

We just switched our entire company over to Zoom’s phone system, and it’s a nightmare simply due to the fact there’s barely any modification that can be made with how it interacts with Windows - We went from Ringcentral to Zoom, and I wish we never did, because it’s awful.

Do something about your Zoom Call interface, instead of ignoring complaints.

1 Like

We have the same issue when screen sharing is started. We would like the shared window (VLC player or Preview) to get the focus. Instead the screen sharing toolbar captures the focus and when pressing space the toolbar jumps forth and back between the bottom to the top of the screen. I had expected the video playback to start, as the VLC window looked focused. Weird…

3 Likes

This is the worse. Using Pixelbook, ChromeOS so web version of Zoom. And especially during a call where people keep on sharing, unsharing their screen this gets really annoying.

2 Likes

I also get disrupted and annoyed by this issue every time another call participant shares their screen.

2 Likes

Have they found a solution yet for this or is still going to annoy us all

2 Likes

I have lost count of the number of times I tried to use a keyboard shortcuts to close some other window but then Zoom steals focus so I leave the meeting. Even worse when Zoom is trying to connect to a new meeting, and I ⌘+W to close the browser tab. I end up closing the Zoom window every. single. time.

1 Like

I’m experiencing the same on a Mac (BigSur). I don’t experience this on Windows 10.

1 Like

This focus-changing issue is a constant source of frustration for me. The host of the meeting will change whether or not they’re screen-sharing and my computer (MS Surface, Windows 10) changes focus away from zoom. So I have to go find the zoom window again in order to participate in the meeting.

1 Like

Yes. Exactly this on my Mac. During demo meetings where people start and shop sharing repeatedly, Zoom just has to drag focus away from whatever I’m doing every…single…time. I don’t often have to be actively paying attention during these meetings so it’s more than a minor annoyance when every few minutes Zoom interrupts what I’m doing. It’s pretty much my only complaint about Zoom, but it’s a big one.

2 Likes

Same problem here on macOS Big Sur. This seems to be a regression in a recent version of Zoom, the issue only started happening when I updated from version 5.0.1 to 5.5.2. Older 4.x versions were not affected either.

2 Likes

See the same problem in Linux working with multiple desktops under XFCE4. Zoom devs, please fix.

2 Likes

This is one of the most annoying things about this program (not to mention the huge invisible parts of the incoming call window). Is this something that can be fixed in ~/.config/zoomus.conf? If so, how come there’s no man page or any online documentation listing and explaining the options that are conveniently missing from the UI?

2 Likes

I have noticed this happening every time the main window of zoom, the meeting window, “reopens”. This includes,
When you join a meeting and the loading screen opens,
when the waiting screen opens,
when the meeting opens,
joining breakout rooms,
leaving breakout rooms,
meeting ends.

Turning this “feature” off for each of them will be very appreciated, more so if it can optionally be turned on/off for certain events.

2 Likes

Got access to this community to add my voice here.

2 Likes

This thread is nearly a year old now. Looking for something on this thread where I can upvote this issue. It should be a simple fix. Don’t assume focus unless the user clicks on your window. Let me work in the background without interrupting my work.

2 Likes

Allegedly the solution here is Settings → Share Screen → Maintain current size.

I tried your suggestion, but zoom keeps on stealing focus when I start a meeting.

Zoom steals focus at serval annoying moments, such as

  • at startup
  • when starting a new meeting.

Hopefully zoom team will add an explicit option to turn off in settings to disable the current behavior, for now I switch to Microsoft Team whenever I can, it does not interfere with focus.

Still seems to be an issue as of Version 5.8.1

Can’t understate how annoying it is to be resolving tickets or writing emails only to have focus stolen about two to three times a minute.