Problem Adding iOS SDK to wrapper

Description
Im not able to install the SDK on my xcode project using react native and node.js

I followed all the steps in the guide to add the sdk to my project without success.

The error: ld: symbol(s) not found for architecture x86_64 .

Even when I try to run your app example console I got same error.

Which iOS Video SDK version?
v5.9.3.2512

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. I downloaded the sdk-to-wrapper from the app page in zoom marketplace (v5.9.3.2512)
  2. I installed via yarn the latest sdk package (yarn add install @zoom/react-native-videosdk --save). It said I have 1.1.1 v
  3. I ran cocoa pods install script (npx pod-install)
  4. I opened xcode project ios and added the folder (MobileRTC.xcframework) to my Embeddeds
  5. I started my node server (everything is fine)
  6. I started ios-simulator (error)

Smartphone (please complete the following information):

  • Device: [e.g. iPhone 11] SIMULATOR
  • OS: [e.g. iOS 12]

Updating: apparently @zoom/react-native-videosdk version 1.1.1 is the main problem, when I just installed (without adding sdk v5 to wrapper library), then cocoa pods install and finally react run-ios, it crashes with the error mentioned: ld: symbol(s) not found for architecture x86_64 .

Would you mind help me, please?
Regards

Hi @edtrainerbi, thanks for using our SDK.

Based on the version numbers provided, it looks like you are trying to use the Meeting SDK with the Video SDK React Native wrapper. Please try downloading the correct SDK and let me know if you’re still running into any issues. Note that you will need a separate account for the Video SDK. More information can be found here.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.