Record Zoom meeting

Hi Zoom Team,We are trying to add ability to record zoom meeting in the meetings for that we are using the below APIs

  1. https://api.zoom.us/v2/users/{userId}/meetings

we tried using the below settings in the above API
auto_recording = “cloud”,
cloud_recording = true,

  1. https://api.zoom.us/v2/live_meetings/{meetingId}/events

still we are not able to see record option in the zoom meeting.This is the ID info@focalpointk12.com which we use to login to zoom account. Can you please verify and let me know whether cloud option to this above zoom account is enabled or not.

Hi @swathi.a

Thanks for reaching out back to the Zoom Develope Forum, I am happy to help here!
Are you creating the meeting via API and setting “auto_recording” = cloud?

The second call that you are sharing, are you passing the field “method” = recording.start ?
Could you share with me the patch request body that you are sending so I can troubleshoot this issue further please?

Best,
Elisa

Hi @Elisa,

Thanks for reply.
Yeah I created meeting via [https://api.zoom.us/v2/users/{userId}/meetings] API and setting “auto_recording” = cloud.

My second API call [https://api.zoom.us/v2/live_meetings/{meetingId}/events]
request body:
{
method:“recording.start”,
params:{
contacts :[{email:“2-12-06A17828@focalpointk12.net”, id:“UblSK87yR7ihXeOJuhfjqw”}],
invitee_name:“Teacher1 Testing 1”,
phone_number:“9999999999”,
invite_options:{require_greeting:true,require_pressing_one:true},
call_type:“h323”,
device_ip:“45.112.29.48”
}
}

Amazing @swathi.a
Allow me some time to debug this issue and I will come back with an update shortly :slight_smile:

Hey @swathi.a
Could you please share the request body that you are sending when creating the meeting please? I am not able to replicate this issue.
I am passing “auto_recording” = cloud and as soon as I start the meeting, it starts recording the meeting.

-Open the Zoom application on your mobile. Start a meeting and then press “More” > “Record”.
-Then it will start the recording, and you will see the “Recording” icon on the screen. Here you can press the icon to stop or pause it.
-Once done, you can view, share, and download Zoom recordings from your Zoom account.

Regards,
Rachel Gomez

https://api.zoom.us/v2/users/UblSK87yR7ihXeOJuhfjqw/meetings

{
“agenda”:“meeting testing”,
“duration”:null,
“end_time”:“13-07-2022 09:00:00 PM”,
“password”:“J04AQ”,
“recurrence”:null,
“settings”:{
“alternative_hosts”:null,
“approval_type”:2,
“audio”:“both”,
“auto_recording”:“cloud”,
“cloud_recording”:true,
“cn_meeting”:false,
“contact_email”:null,
“contact_name”:null,
“enforce_login”:flase,
“enforce_login_doains”:null,
“global_dial_in_countries”:null,
“global_dail_in_numbers”:null,
“host_video”:false,
“in_meeting”:false,
“join_before_host”:false,
“local_recording”:false,
“meeting_authentication”:false,
“mute_upon_entry”:false,
“participant_video”:false,
“recording_authentication”:true,
“use_pmi”:false,
“waiting_room”: false,
“watermark”:false,
},
“start_time”:“13-07-2022 08:00:00 PM”,
“timezone”:“UTC”,
“topic”:“Meeting Jul 13”,
“type”:2
}

Hi @swathi.a

It looks like you are passing an extra field in you request.
You do not need to pass the field “cloud_recording”:true
You only need to pass “auto_recording”:“cloud”

Hi Elisa,

Now I passed “auto_recording”:“cloud” in first API call https://api.zoom.us/v2/users/UblSK87yR7ihXeOJuhfjqw/meetings

Even though I got error message for second API https://api.zoom.us/v2/live_meetings/{meetingId}/events

“code”: 3001,
“message”: “Meeting does not exist: 84586796605.”

Hey @swathi.a
Did you call the second API while the meeting was live?
Could you share with me the link to the documentation that you are referring to please?

Cheers,
Elisa

Hi Elisa,

Now issue solved, I called second API while the meeting was live.

But I am unable to pause / stop the meeting recording until unless End the Meeting. Is there any API required or any option is there? Can you please give the solution.

Thanks

Sure @swathi.a
With the endpoint Use in-meeting controls, you should be able to perform that action.
You will have to pass “recording.pause” or “recording.stop” as the value of the field “method”

Here is the link to our Docs: