Rejoin to the meeting error

Description
A user can’t enter to the example demo app after a user enters the wrong meeting ID and tries to join with the correct one after it. (Steps to reproduce bellow).

Which version?
Xcode 10.3
Mac OS 10.15.7

To Reproduce(If applicable)
NOTE: This issues appears only when user checks “Custom UI”

Steps to reproduce the behavior:

  1. Start the example demo app
  2. Enter a domain and check “Custom UI”, click Connect
  3. Enter a jwt, click Auth
  4. Switch to “Join Only” tab
  5. Enter Info, but with a wrong meeting ID (for example)
  6. Change meeting ID to correct, click Join
  7. A user can’t enter to the app, even with the correct meeting ID.

Hi @anton.yereshchenko, thanks for the post.

I have been able to consistently reproduce this behavior in our sample app. Thank you for bringing this to our attention, we will look into fixing this.

Thanks!

1 Like

Hi @jon.lieblich, thanks for the reply.

May you tell when it will be fixed, approximately of course.

Thank you a lot!

Hi @anton.yereshchenko,

Unfortunately with the holidays approaching, it may take some time for us to get around to fixing this due to limited engineering bandwidth as we approach the new year. Be sure to keep an eye on the sample app repo for updates.

Thanks!

Hi @jon.lieblich,

Ok, I see, could you advice some trick, to handle this issues for now?
Because, for example, I tried to reinit the SDK:

ZoomSDK.shared()?.initSDK(with: params)

and got the error:

Assertion failed: (!m_tmID), function SetTimer, file /Users/zoom/Jenkins/zoomcode/client_sdk_2019_kof/Common/client/utility/include/CmmTimer.h, line 35.

Maybe is there a some silver bullet for now to use the SDK and don’t relaunch the app after entering the incorrect meeting iD?

Thank you!

Hi @anton.yereshchenko,

When you say you tried to reinit the SDK, do you mean that you are calling initSDK twice within the same session? Once the SDK has been initialized successfully, there is no need to call this method again.

Thanks!

@jon.lieblich thank you for your help!

I am using new version of SDK

zoom-sdk-macos-5.4.54528.1230

and this issue is solved.

Thanks!

That’s great, happy to hear the new SDK version resolved this issue!