REST API V2 - Create a Meeting not showing on API call

Description
Unable to use Meetings POST route correctly. API POST meeting results in success, and a meeting is created as you can join the meeting from the responded URL, however, the scheduled meeting does not show up on the /users/:id/meetings route, or under my accounts upcoming meetings section

My set up is Frontend (VueJs) -> Backend NodeJS Server -> Your REST API.

Code
From PostMan.

POST: localhost:1337/users/{{MYUSERID}}/meetings

JSON Body RAW:

{
"duration": 60,
"settings": {
	"approval_type": 2,
	"audio": "both",
	"auto_recording": "local",
	"close_registration": false,
	"cn_meeting": false,
	"enforce_login": false,
	"host_video": true,
	"in_meeting": false,
	"join_before_hos": true,
	"mute_upon_entry": false,
	"participant_video": false,
	"registrants_confirmation_email": true,
	"use_pmi": false,
	"waiting_room": false,
	"watermark": false
},
"start_time": "2020-05-07T13:57:23+0000",
"timezone": "Etc/Greenwich",
"topic": "API Test",
"type": 1
}

Response


{
    "uuid": "{{UUID}}",
    "id": 86552690751,
    "host_id": "{{MYUSERID}}",
    "topic": "API Test",
    "type": 1,
    "status": "waiting",
    "timezone": "Etc/Greenwich",
    "created_at": "2020-05-07T14:59:04Z",
    "start_url": "{{URL}}",
    "join_url": {{JOINURL}}",
    "password": "{{PASSWORD}}",
    "h323_password": "{{PASSWORD}}",
    "pstn_password": "{{PASSWORD}}",
    "encrypted_password": "{{ENCRYPTED_PASSWORD}}",
    "settings": {
        "host_video": true,
        "participant_video": false,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "both",
        "auto_recording": "local",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "global_dial_in_countries": [
            "US"
        ],
        "global_dial_in_numbers": [
            {
                "country_name": "US",
                "city": "New York",
                "number": "+1 6468769923",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "San Jose",
                "number": "+1 6699006833",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "Tacoma",
                "number": "+1 2532158782",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "Germantown",
                "number": "+1 3017158592",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "Chicago",
                "number": "+1 3126266799",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "Houston",
                "number": "+1 3462487799",
                "type": "toll",
                "country": "US"
            },
            {
                "country_name": "US",
                "city": "San Jose",
                "number": "+1 4086380968",
                "type": "toll",
                "country": "US"
            }
        ],
        "registrants_email_notification": true,
        "meeting_authentication": false
    }
}

Hi @afletcher53, thanks for posting & using Zoom! In your Request Body, you’re setting the meeting as an instant meeting (type: 1), rather than a scheduled meeting (type: 2). Here’s the reference, if needed.

Let us know if we can help further :slight_smile: