Retrieve Zoom Token

Trying to start a meeting from given mobile sample.
Provided with my web API Key and web API Secret.

Able to get the JWTAcess token and Zoom Access token but unable to get Zoom token for the user.

Getting empty braces as response, i can provide you with my keys if required.

Followed from the above link even, but i
am not getting any response.

Which version?
v4.6.21666.0429

Hi @priyakvb,

Thanks for the post. I just tested our demo app and the corresponding part is working.

Please have a try, hope this helps. Thanks!
3.

HI Carson,

I really appreciate your response, I tried the same, for your reference i am providing all the keys of mine with all the response, please have a look at these and do the needful.

JWTAcessToken : ***********

**Requesting ZoomToken **


Responce {}

Request ZAK


Responce
{
“token”: “***********”
}

SDK Key


SDK Secret


Provided with all the credentials you had stated above, Let me know if you require anything else or where exactly i am wrong so that we can fix the issue asap.

Looking forward for your reply…

Hi @priyakvb,

Thanks for the reply. I have edited your response since you have provided your SDK credentials here. This is a publicly available forum so please do not post any sensitive credentials here. If you need to provide private information in the future, please let me know and I will provide a way to achieve that. Please re-generate your SDK credentials on the Marketplace as soon as possible since I am not sure how many people have seen your credentials before I see it.

Back to the issue you are facing, thanks for providing the info. I tried to test the tokens you have provided, and the tokens in “JWTAccessToken” and the access token in the “Requesting Zoom Token” are not valid. It is expected to receive empty response if the JWT token is not valid. The access token in the “Request ZAK” is valid but expired.

Please make sure you are using API key & secret to form the JWT token when communicating with the Zoom API and please double check the JWT token you are using to retrieve the Zoom token. You may also refer to the instruction here to generate the JWT and test it:

Hope this helps. Thanks!

Hi Carson,

I really appreciate your response,
Tested everything from my end and even generated new SDK secret key, but still not getting the zoomToken.
Please let me know where to provide the keys i am using and if there is any possibility to share my query on call so that i can show the exact issue by sharing my screen.

It will be really helpful if you can arrange this so that it will be feasible to resolve the issue quickly.

I forgot to mention, i am using the Zoom provided sample code.

Looking forward for your reply…

Hi @priyakvb,

If you are sending requests to Zoom API, you will need API key &secret instead of SDK key & secret. Since Zoom API and SDK are 2 different products, they are not using the same credentials. You may refer to the instruction here to test your requests with Zoom API:https://marketplace.zoom.us/docs/api-reference/using-zoom-apis; Please have a try with other Zoom API and see if it works.

Thanks!

Hi Carson

I really appreciate your response.
As per your suggestion i had changed the SDK Key,

For getting the ZoomAPI key, i am using the API key, API Secret key only, able to generate JWT Token and ZOOM Access Token, but we are still getting Zoom User Token as blank{}.

It will be really helpful if you can arrange a call so that i can share my screen, so that it will be feasible to resolve the issue quickly.

Looking forward for your reply…

Hi @priyakvb,

Thanks for the prompt reply. That’s unexpected. I understand what you are experiencing but I could not reproduce it on my side. As the issue you are facing is related to the usage of API, let me forward your question to the API section and have one of the API experts to help you.

@Michael_Purnell Could you help with this? Thanks!

I am getting same issue in my application. I have create sdk type app at zoom developer account. After that i hvae sucessfully init sdk and get jwt token but unable to get zoom access token, i am getting Zoom Token as blank{}, i am using ‘https://api.zoom.us/v2/me/token?type=zak&access_token=" + JWT_TOKEN’
api to get accesstoken and also not getting anything from type=token

Hey @kathuriasimran94,

Make sure the Zoom user you are trying to get the token for has signed into Zoom using the email flow.

If they have just signed in using google auth it will not return the token.

Thanks,
Tommy


hello,
Thank you for your response. Yes previously i was using google auth but i have created account using email flow but still i am getting empty string as response and also also service in sdk are null, and i want to know if i want to create meeting in my application Is it necessary to login zoom in app first?

Hey @kathuriasimran94,

Can you try passing in your userID instead of me when requesting a token with JWT? Also try adding the ttl param.

https://api.zoom.us/v2/users/{userId}/token?type=zak&ttl=3600

Thanks,
Tommy