SDK 1.7.9 - Recaptcha feature documentation

@Michael_Purnell Can you expand on why this post is a ‘solution’.

I read it as “we understand your concerns but we are going to do nothing about this, but we will send an email to some internal people”

Some info on what your future plans are would be helpful (we’ll add a disable option or even - this is just how it is guys, deal with it) would help us as we deal with this unforeseen issue…

1 Like

Hey @puravt,

Please see instructions on how to handle the incognito error here:

We have also released version 1.7.10 which fixes an issue where reCaptcha doesn’t work for when the “-” character is within the domain name:

Thanks,
Tommy

Hey @pomalley,

We are currently exploring the possibility to add an option to turn the recaptcha off.

Thanks,
Tommy

2 Likes

Hey @harish.venkataraman,

Let me find out.

Thanks,
Tommy

Hey everyone,

If you would like to request your account be whitelisted to remove the recaptcha feature, please fill out this form:

Thanks,
Tommy

3 Likes

Hi @tommy,

We have multiple accounts in our company but I can only fill out the form once. What should I do?

Tommy,

We have multiple customers. We use their generated keys. So now, in addition to generating keys, we will have to opt out for each customer. Better than nothing I guess. What I will need to know though, is how long will it take from time of submission till it is turned off? Again, think of use cases. We are embedding for multiple customers. Perhaps it would be better to have this listed as an option on the Zoom marketplace screen where the keys are generated?

Mike

Also, btw - I am still interested in hearing the logic behind requiring this - can you comment? Due to the fact that you require a generated signature to use the webSDK , how is the added RECAPTCHA helpful to Zoom security?

1 Like

Hello, when i join meeting whith zoom reCaptcha integration it says you are in incognito mode is in use… help me please

@dodigerman2

  1. which web SDK are you using ? If not the 1.7.10 then update to 1.7.10 as it contains a fix related to domain names covered by the reCaptcha feature
  2. if you already use the 1.7.10, can you communicate the domain name of your application to zoom team so that they ensure their fixed domain name regex cover correctly your application domain name ?

UPDATE: I have inconsistently got this working on Firefox as Guest. Sometimes it works, others not. Does not work in Chrome incognito mode. This is my sandbox attribute on my iframe.

 sandbox="allow-forms allow-scripts allow-same-origin allow-popups allow-modals"

@tommy @Michael_Purnell … 1.7.10 still doesn’t work. Still broken code is released. Still no solution to the damn recaptcha functionality you guys unnecessarily added. This incompetency is costing our business thousands of dollars due to delayed releases. I am the CTO for our company, and I am not risking our business due to third party broken code. Unfortunately, we don’t have the option of changing providers as we already pay a great deal to Zoom for our account.

I applied for the opt-out of the recaptcha, but have no idea when that will take place. I used our Company Account number. I hope I wasn’t supposed to use a specific user account number as that would be disastrous given we intend to create hundreds of them.

It took you guys 11 days to add a character to a regular expression and fixed something that was not broken in previous releases, but got broken in subsequent releases.

Please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please prioritise removing this broken, useless, unnecessary reCaptcha functionality, or if it really must be kept in, give us an option to not require it with our integrations.

The screenshots attached show it is still broken on a local dev machine with a valid SSL certificate and no incognito mode. The host of the meeting is on Chrome (normal window) and the guest (which is broken) is on Firefox.

1 Like

@SimoneLabianca,
We understand your concerns about the current issues with the WebSDK. However, please be advised, that the use of vulgar language on the forum is not welcomed.
We strive to provide a community experience that is welcoming to everyone. Please make sure to follow our guidelines which state that titles, posts, links, etc, should be safe for “family and friends”.

With that in mind, @tommy has posted the link to opt-out of the reCaptcha feature. If you filled it out, our team will be removing the reCaptcha feature from your account this week so that you can continue developing.

Thank you for your patience.

@Michael_Purnell … sorry … what vulgar language? The only two words that may have any inclination of being harsh are “incompetency” and (removed) Neither of which can in any way shape or form be interpreted as “vulgar”.

I have attached a screenshot of the Oxford Dictionary definition of the word “damn” to prove my point as well as indicate which version of the word I was using. I used it in adjective form to further express my frustration at the situation.

Screenshot Removed

As for incompetency, if offence was taken by its use, I apologise, but you really need to put yourself in our shoes. Since 1.7.7 we’ve been dealing with system-breaking bugs introduced with each new release, culminating with this recaptcha tech. For commercial usages that equates to a lot of money in potentially lost business, not to mention developer time trying to find solutions.

I’ll wait to know when and if the recaptcha is removed from our account before continuing development.

Thank you.

@tommy - Well, another complaint from me!. I have to submit this for multiple customers. The google form requires login and only allows one submission. Sigh.

1 Like

When you say to send my application Domain name , what do are you reffering , acttualy?
Thanks,
Dodigerman

Please let us turn reCaptcha off. Staying on 1.7.8 as long as possible.

2 Likes

We are managing many customer account. We can fil the form and white list for few. We cannot do this for all customers. Please give a hotfix where we can pass this as query parameter to disable or account level setting.
It does not work at all in iPhone and iPad.
Fix to feature which are broken cannot take days. Please act on it.

If your application is accessible through the following URL https://myapp.com/zoomintg, i refers to myapp.com

I got it now.

I am still doing test
through http//:localhost then I will move it to http//:mydomain.com.

Please help. Thank you

When can we expect the opt-out to happen? We too are experiencing same issues as @SimoneLabianca with 3110 errors although app is running on port 80. Error message is not helpful at all and just contains url “https://zoom.us/webSDK/recaptcha” and message “Fail to join the meeting”