Sdk auth no longer working

Description
I have an app that authenticates to zoom and automates certain tasks. This app has been working in the past and recently as last Friday. Today we are encountering an error regarding authentication.

I’m seeing this error, onAuthenticationReturn: 2 (AUTHRET_KEYORSECRETWRONG), when trying to do SDK auth. Is there anything that may have recently changed to have caused this ?

I have verified that the key / secret that we are using is correct. I’ve also tried generating a new secret, but getting the same errors. I’ve also tested using the same key / secret using the electron sdk and its also being rejected there. Seems there is an issue with out key / secret.

Which version?
Zoom Windows SDK v4.6.21666.0428

Smartphone (please complete the following information):

  • Device: Windows Desktop
  • OS: Windows

Additional context
Add any other context about the problem here.

It looks like the issue is related to the company account that I am using. Even when I tried to regenerate the sdk secret the authentication still doesn’t work, but when I made a new account and created a new sdk app with a new key and secret, those new keys and secret worked.

Is there any way that I can clear the key / secret that is associated to my company account ?

Hi @thanh.thai,

Thanks for the post and for pardon the late response. My colleague said he has already helped you with this and it should work now. Please let me know if it is still not working.

Thank you.