Set Call Plan via Okta > Zoom Integration

Description
Trying to set the Call Plan via advanced SAML response settings and have configured it as noted in this document (Setting up advanced SAML mapping – Zoom Help Center) but the call plan is not being set.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Okta to Zoom integration.

Additional context
We’re able to set the addonPlans successfully.

Hey @austin.greca,

Thank you for reaching out to the Zoom Developer Forum. Are you able to share an example of how you’re mapping the call plan? Either a screenshot of the web portal or a SAML snippet should help out here.

If you don’t want to share that on the forum, please send an email to developersupport@zoom.us with a link to this thread.

Thanks,
Max

Thanks for the reply, Max. This is how we’ve configured it in the Zoom SAML Advanced mapping side. On the Okta side, we made it so the addonPlan attribute contained “phone” for specific groups. This worked like a charm for the Webinar and Large Meeting licenses but not for Call Plan.

Hey @austin.greca,

Thanks for following up with that information. Please send an email to developersupport@zoom.us with a link to this thread.

In that email, please include screenshots of how you have configured Okta. If you’re able to provide a video of the issue that would be helpful too. I’ll use this information to get in contact with our engineering team if necessary.

Thanks,
Max

Hi @MaxM ,

We will not be able to reproduce the issue since we only have our one environment and this will directly impact live users. When the issue occurred the first time we had users sign in and lose their call plan and we had to reach out to them to find what their direct dials used to be since that data wasn’t retained anywhere.

I forgot to mention that after the Zoom screenshot in my previous reply was taken, we changed the property to “callPlan” and checked if it contained “unlimited”.

We thought maybe having two properties set by the same attribute was causing an issue so we created a new attribute called “callPlan” to eliminated variables.

I keep getting an error when attempting to post this saying I can’t embed media into a post. Is there any way I can direct message you the image?

On the Okta side we have a Group configured within the Zoom application with the following settings:
userType = 2
userRole = member
addonPlan = webinar, large
callPlan = unlimited

Hey @austin.greca,

Thank you for following up on this. The best way to get in contact and send direct messages is to email us at developersupport@zoom.us.

By adding a link to this thread, that will make sure the ticket that is created gets assigned to me.

I’ll follow up with you there where I should be able to be more responsive as well.

Thanks,
Max