Setting isSupportAV false also disables the incoming audio

Description
I need to disable audio for certain users in zoom meeting, i try to set isSupportAV as false and it disabled the audio for them, but they can’t also hear anything. Is there a way to do it ?

Which Web Meeting SDK version?
1.9.7

To Reproduce(If applicable)
pass isSupportAV as false in ZoomMtg.init

Device

  • OS: [macOs]
  • Browser: [Chrome]

Hey @uday_skuad,

Thank you for reaching out to the Zoom Developer Forum. Try setting disableJoinAudio to true in the init() function.

Let me know if that helps.

Thanks,
Max

@MaxM it didn’t have any effect

Hey @uday_skuad,

That’s my mistake, I meant to say set that property to true. Let me know if that has an effect.

Thanks,
Max

@MaxM it doesn’t fit my use case. It only disables the join function on meeting screen. User can still mute/unmute from the splash screen(which comes before joining) and also from participants list

Hey @uday_skuad,

Thanks for testing that out and getting back to me! You can disable the preview when a user joins by setting disablePreview to true. That should prevent the user from unmuting via the participants list as well.

Let me know if that helps.

Thanks,
Max

@MaxM It didn’t work. It just disabled the splash screen. User can still mute/unmute from participants list

Currently i setting mute using setInterval

setInterval(()=>{
  ZoomMtg.getCurrentUser({
    success: (data: {
      result: {
        currentUser: {
          muted: boolean;userId: Number
        }
      };
    })=>{
      if(audioVideoDisabled&&data?.result?.currentUser?.muted===false){
        ZoomMtg.mute({
          userId: data?.result?.currentUser?.userId,
          mute: true,
          
        });
      }
    },
    
  });
},
1000);

Hey @uday_skuad,

Thanks for getting back to me. I’ll check with our team to see if there is a better method to accomplish this and let you know what I hear.

Thanks,
Max

Thanks @MaxM. Please let me know i would like to avoid using setInterval

Hey @uday_skuad,

Apologies for the delay here, I have a team meeting tomorrow where I can bring this up.

Thanks,
Max

Hi @MaxM, is there a new status for this issue ?

Thanks
Uday

Hey @uday_skuad,

Thanks for your patience. The solution here is to set disableJoinAudio to true and also disablePreview to true but as you mentioned it seems there are still ways for the user to join audio when doing this.

I’ve reached out to our engineering team with these issues and will get back to you as soon as I know more. (ZOOM-311274)

Thanks,
Max

1 Like