Share screen button not visible in Client Web SDK 2.1.1

Hi,

We are using Zoom’s Client Web SDK [2.1.1] and as shown in the image below, the “Share screen” option doesn’t render in the “More” section of the toolbar. However it does show up in the toolbar itself when the view size increases (and subsequently, the “More” button hides itself).

zoom-no-share-screen

As you can see in the screenshot, there is an empty cell which, we believe, should have had the “Share screen” option. Clicking on that empty cell throws the following error:


Uncaught TypeError: e.handleOnClick is not a function
    at onSelect (zoom-meeting-2.1.1.min.js:2:3507431)
    at zoom-meeting-2.1.1.min.js:2:537732
    at t.handleClick (zoom-meeting-2.1.1.min.js:2:2238443)
    at t.handleClick (zoom-meeting-2.1.1.min.js:2:982470)
    at Object.sh (react-dom.min.js:164:410)
    at rh (react-dom.min.js:13:429)
    at uh (react-dom.min.js:13:483)
    at Ge (react-dom.min.js:15:158)
    at vh (react-dom.min.js:165:250)
    at ad (react-dom.min.js:15:443)

A confirmation of the bug and a solution will be most appreciated.

Thanks

Hi,

Can you show us the code where you call the init function ?
Maybe you forgot to add the Share screen in the init function
Check all the options you added here : https://marketplace.zoom.us/docs/sdk/native-sdks/web/client-view/reference#init

Hi!

Thanks for the response. We are initializing the meeting correctly with screenShare set to true. The button is still not visible.

@moogway Make sure you’re serving the site over HTTPS with something like Ngrok. If that doesn’t help, try testing with the Sample Web App and let me know if that helps.

Hey Max,

Thanks for the response. We tried the sample app (served over https with ngrok) but even there the share screen button hides itself if the window is resized. If the window is expanded, it appears in the bottom toolbar. Attached are the screenshots.

View - resized and shrunk

View - full size

It seems like a bug with the SDK.

Thanks!

@MaxM
We also have this issue within our application when we upgrade. Would be nice to have a look at it, it’s quite impacting for users since almost all minimize / resize the window during a meeting at some point.

@moogway
It seems that the latest version release (2.2.0) fixed it.

The very bad point of release 2.2.0, if you are hosting zoom resources by yourself instead of using the CDN, you will have to update zoom source code from their npm package to fix two returned type that are bugged, as explained on the release note here.

1 Like

@nvivot Thank you for sharing the solution as well as the caveat with the new version.

@moogway Let me know if that update resolves your issues.

Thanks @MaxM ! Upgrading to the latest release fixed it for us too.

Hi @MaxM,

Do you have an update about @nvivot remarks below? We are having 2nd thoughts on updating our app to use v.2.2.0 yet because of this so we would appreciate it if this can be addressed soon on Zoom side.

The very bad point of release 2.2.0, if you are hosting zoom resources by yourself instead of using the CDN, you will have to update zoom source code from their npm package to fix two returned type that are bugged, as explained on the release note here .

Thanks,
Lara

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.