SuccessFactors LMS timezone syntax

Using this template helps us debug your issues more effectively :slight_smile:

Timezone syntax value for Zoom meeting
I’m using the SAP SuccessFactors LMS system, and when I schedule a meeting from LMS system the timezone i select in my LMS system is “Asia/Kuala Lumpur”. But in the Zoom meeting the time zone is goes to UCT time. May i know what is the syntax value for timezone support in Zoom meeting?

Error
No error only timezone value incorrect showing in zoom meeting.

**JWT **
I’m create the JWT to get the API key and configure in our LMS sytem

Which Endpoint/s?
<connector_class>com.successfactors.lms.framework.vle.impl.ZoomConnector</connector_class>
<url_api_address>https://api.zoom.us/v2</url_api_address>
<connector_type>meeting</connector_type>

POST request to https://api.zoom.us/v2/users/{userID}/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Schedule a virtual training in SAP SF LMS system with timezone “Asia/Kuala Lumpur” timezone
  2. Zoom meeting show UTC timezone

Screenshots (If applicable)
The time zone schedule in SF LMS system is 02:30 PM under Asia/Kuala Lumpur Malaysia time.
But in Instructor Zoom Meeting the time zone showing incorrect

Additional context
Add any other context about the problem here.

Hey @sychia,

Thank you for reaching out to the Zoom Developer Forum. Please make sure that your SuccessFactors integration is setting the start_time field with an applicable timezone when calling the Create a Meeting API:

image

Let me know if that helps. If not, SAP support should be able to offer more insight into integrating with Zoom and how the Timezone field can be set.

Thanks,
Max