SWIFT SDK crash on join meeting and error 150 when I try to create a meeting

HI,

I’m very new to Zoom SDK.

I’m try to integrate in my swift app and I import all lib and I use the library https://github.com/george-lim/zoom-service to use it in swift.

But when I’m try to join a meeting the app crash with this error reason: '-[ZoomExemple.AppDelegate window]: unrecognized selector sent to instance and if I try to create a meeting I have error 150 InvalidArguments

Hi fabio.cirruto,

Thanks for using Zoom SDK. The crash and the error code are 2 separated issues:

Error code: 150 means invalid arguments (https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/resource/error-codes#14-meeting-error-codes ). Please double check whether you pass the correct information as the parameter to start/join the meeting. Please ensure you have the correct: keys & secrets, display name, meeting number.

The error reason: '-[ZoomExemple.AppDelegate window]: unrecognized selector sent to instance might not relate to our SDK, please see the following links:

If you are still experiencing this crash, please kindly provide your .crash file and your SDK log so we can further investigate this issue. Thanks!

Hi Carson,

Thank for your help.

For the error code 150, I have only on Create Meeting and this is an example the param [“kMeetingParam_MeetingPassword”: “p”, “kMeetingParam_Username”: “Fabio Cirruto”, “kMeetingParam_MeetingNumber”: “882182316”]

I set the correct key because I copy from this:

For the crash I see your link and the problem there is when I use swift to access objective-c function, this is the incriminate function (MobileRTCMeetError)startMeetingWithDictionary:( nonnull NSDictionary*)dict;

But I’can’t understand how I can resolve it

Hi fabio.cirruto,

Thanks for the reply and the info. Are you able to pass the SDK initialization and authentication? Are you using email/password login or authenticating via API(get tokens)?

Thanks!

Hi,

I’m using email/password.

In my didFinishLaunchingWithOptions of AppDelegate I run this ZoomService.sharedInstance.authenticateSDK() this is the code of the function:

func authenticateSDK() {

guard let zoomSDK = MobileRTC.shared() else { return }

zoomSDK.setMobileRTCDomain(ZoomAPI.domain)

guard let authService = zoomSDK.getAuthService() else { return }

authService.delegate = self

authService.clientKey = ZoomAPI.appKey

authService.clientSecret = ZoomAPI.appSecret

authService.sdkAuth()

}

Then in my ViewController when I press the join button I run this:

@objc func joinMeeting(name: String = ZoomAPI.defaultName, number: Int, password: String = “”) {

guard isAPIAuthenticated || isUserAuthenticated, let meetingService = MobileRTC.shared().getMeetingService() else { return }
var paramDict: [AnyHashable : Any] = [
  kMeetingParam_Username : name,
  kMeetingParam_MeetingNumber : "\(number)"
]

if password.count > 0 {
  paramDict[kMeetingParam_MeetingPassword] = password
}

meetingService.delegate = self

let returnValue = meetingService.joinMeeting(with: paramDict)

guard returnValue == MobileRTCMeetError_Success else {
  print("Zoom: Join meeting task failed, error code: \(returnValue.rawValue)")
  return
}

print("Zoom: Join meeting task completed.")

}

And the crash is on let returnValue = meetingService.joinMeeting(with: paramDict) row

Hi @Carson_Chen,

I resole the join meeting error.

I work with 11.1 and swift 5.

In this version the old AppDelegate is separated in AppDelegate and SceneDelegate.

The old window property of AppDelegate are moved to the SceneDelegate and this is a problem when presenting the Zoom Pages.

I resolve this with a workaround. With an old version of Xcode I create a new project and then I open and work the project with the last version of Xcode and now I can join meeting also with my iPhone with IOS 13.*

I hope you can resolve this problem as soon as possible.

Many Thanks for your time.

Fabio

Hi
We do not yet support xcode11, we will support xcode11 in future releases, please watch our release information
Thanks