Test Request Uploading virtual background not working

Description
Attempting to upload a virtual background in the test request section of https://marketplace.zoom.us/docs/api-reference/zoom-api/users/uploadvbuser
I have tried a similar request with upload profile picture POST request and get a similar error
I have tried with multiple different images in different formats and nothing seems to work

Error
{
“code”: -1,
“message”: “Required request part ‘file’ is not present”
}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

How To Reproduce (If applicable)
Steps to reproduce the behavior:
POST https://api.zoom.us/v2/users/me/settings/virtual_backgrounds

Headers:
Authorization: Bearer
Content-Type: multipart/form-data

Body:
{
“file”: “”
}

Anyone have any idea what’s wrong?

Hey @ido1,

Thanks for reaching out about this.

As a first step, can you make sure you’re passing the file as multipart/form-data? If you attempt to pass the file path as a string in your request body JSON, I don’t believe this will work.

Let me know if making this change gives you better luck!

Best,
Will


Is there something wrong here that I’m not seeing? The file is a public image on s3, but I’ve tried other public image urls and always the same error

Hey @ido1,

Can you check that you’re passing the following header as well?
Content-Type: multipart/form-data

Let me know—thanks!
Will


Yeah, it’s there by default it seems

Thanks for confirming @ido1. Do you run into this same error when you download the file locally and pass the relative path as the value for file?


Also tried this, but maybe I’m messing up the format?

Hey @ido1 ,

Checkout this thread for uploading a photo via the Zoom API:

Let me know if that helps! :slight_smile:

Thanks,
Tommy