There is no audio after joining the meeting

Description
Hi, there. We’re building a SPA using React.js, and we have integrated @zoomus/websdk v1.8.3 to join zoom sessions. We’re embedding an iframe, which is rendering zoom player component in it.

// Component1.js
<iframe src={'/zoom_player/' + sessionId} allow="camera;microphone" />

// ZoomPlayer.js
import { ZoomMtg } from '@zoomus/websdk';
...
useEffect(() => {
// ...
try {
  const status = ZoomMtg.checkSystemRequirements();
  // ...
} catch (err) {
  // ...
}
ZoomMtg.setZoomJSLib('https://source.zoom.us/1.8.3/lib', '/av');
ZoomMtg.preLoadWasm();
ZoomMtg.prepareJssdk();
// ...
}, []);

// Init
ZoomMtg.init({
  leaveUrl,
  isSupportAV: true,
  disableJoinAudio: false,
  audioPanelAlwaysOpen: true,
  success() {
    ZoomMtg.join({
      meetingNumber,
      userName,
      signature, // We have our own custom endpoint setup to generate signature
      apiKey,
      passWord,
      success() {
        // ...
      },
      error(err) {
        // ...
      }
    });
  },
  error(err){
    // ...
  }
});

As soon as the above code runs, it’s able to join the zoom session, in which host can share video/screen, but here is a couple of issues happening;

  • There’s no audio at all after joining the session.
  • It’s not prompting to ask “Join with computer audio” when joining the session and it doesn’t show control panel which has Mic on/off, video on/off buttons.

Error

  • There’s no audio at all after joining the session.
  • It’s not prompting to ask “Join with computer audio” when joining the session and it doesn’t show control panel which has Mic on/off, video on/off buttons.

Which version?
1.8.3

Screenshots
If applicable, add screenshots to help explain your problem.

Device (please complete the following information):

  • Device: Desktop
  • OS: Windows, MacOS
  • Version: latest
  • Browser: Chrome v87

Hey @zoom29,

Happy to help! A few things you can try, ensure you are serving your site and the iFrame url over https.

Double check your browser settings to see if you allowed permission to the microphone.

You can also try upgrading to the latest 1.8.5 version where we fixed some audio issues.

Thanks,
Tommy