This project uses AndroidX dependencies, but the 'android.useAndroidX' property is not enabled

pardon me, im new to using sdks
So i have downloaded the sdk provided in the documentation, when i run the app i get the issue:
“This project uses AndroidX dependencies, but the ‘android.useAndroidX’ property is not enabled”

and when i checked StackOverflow i get that i have to upgrade my android project to android x and i have to use the following code in the gradle.properties
android.useAndroidX=true

android.enableJetifier=true

i can’t find the Gradle. properties file and i have no idea where to put the above code, i tried putting it in the following files link

but there is no effect and i still get the above error. can someone please help me figure this out? Thanks in advance!

Hi shane.pereira,

Thanks for using Zoom SDK. It seems like this question is not related to Zoom SDK. If you would like to have the gradle.properties file in your project, you may refer to the following:

Hope this helps. Thanks!

I am also new to Android Studio, I could not find any way from the IDE to add the gradle.properties file, so I added it manually and it showed in the IDE the next time I loaded it. I added those two lines:

android.useAndroidX=true
android.enableJetifier=true

and it works now. gradle.properties needs to go in the solution top folder, i.e. for the samples it would be mobilertc-android-studio.

1 Like

Thanks for sharing! Glad to hear that it is working now. Happy Zooming! :slight_smile: