Unable to get participants from /past_meetings/{meetingUUID}/participants endpoint

Hi Guys.

I’m getting a 400 error when trying to hit /past_meetings/{meetingUUID}/participants endpoint, I’m sure this is not an AUTH problem because in the same run when I’m getting this error I’m using the same token for other endpoints and they are working as expected. The error retrieved by the API is about scope but I’m using the same scope I was using before except that now I added meeting:read:admin

I also try adding all the scopes the API is complaining about, same error.

Running my code without getting participants works just fine (the API doesn’t complain about scopes at all).

I investigated the forums before creating this topic:

Apart from that topic I couldn’t find anything similar. There was another regarding scope but that one was actually a scope issue (mine doesn’t seem, at least not from the surface).

{“code”:4700,“message”:“Invalid access token, does not contain scopes: [meeting:write, zms:meeting:read, meeting:read:admin, zms:meeting:write, meeting:read, meeting:write:admin]”}

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Use meeting:read:admin scope
  2. Try to hit this endpoint h-t-t-p-s://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/pastmeetingparticipants

Screenshots (If applicable)
Asked scopes when completing oauth: https://imgur.com/cXlH8Az

Additional context
I also try with both meeting:read:admin and meeting:read scopes, no luck.

My account is in Pro plan and it has admin role in it.

Any help is really appreciated.


Hey @jarrieta, happy to help!

Can you share the meetingUUID / meetingID you are passing in?

And can you private message me your access_token?

I’m guessing you have tried un installing and reinstalling your App?


1 Like