Unable to join meeting in Google Chrome 2.2.0 (malloc undefined)

I am running the client version of the WebSDK in an iframe.
As a bundler, I use parcel 2.0 and I am loading the ‘/lib’ files locally ( tried the Zoom CDN, but there was no effect)

The problem:
When I am running the project locally or running the project from Firefox, everything works fine.
But when I run the project in Google Chrome on the deployed version I see the following errors(works fine locally).
This error is critical because it is impossible for a user to Join Computer Audio or Camera and participate in the meeting in any way.

Browser Errors:

Which Web Meeting SDK version?

Meeting SDK Code Snippets
ZoomMtg.preLoadWasm(); breaks

To Reproduce(If applicable)
Steps to reproduce the behavior:
Open the meeting on any device in Google Chrome and the critical error occurs.


Additional context
This is how I am importing dependencies:

I would guess, they are loaded correctly since it is working as expected on all browsers except Chrome.

1 Like

I can confirm the same error is present with the latest versions of these browsers:

  1. Chrome on Windows
  2. Chrome on Mac
  3. Brave on Windows
  4. Brave on Mac
  5. Microsoft Edge (on Windows)

Greetings, and Welcome, @manatabg93!

Thank you for posting in the Developer Forum. That error is likely resulting from the use of the iFrame in your implementation. We currently do not offer support and discourage the use of iFrame. More details on this can be found here: Web SDK Gallery View

That aside, testing with our Sample App SDK, I do not see the same behavior. Can you try again with our Sample App and let us know if the behavior is persistent?

Let me know if you have any questions about this.



Thank you for posting as well! Are you able to verify if you are using an IFrame in your implementation? If not, can you share the exact steps to reproduce the behavior you are seeing?


Actually, the issue was not due to the iFrame solution, but to the CSP headers.
We had to use ‘unsafe-eval’ (unsafe-wasm works on Chromium browsers, but not on Safari). It would be nice if this is pointed out somewhere in the documentation of the SDK.

Glad to hear you were able to resolve that issue by using the “unsafe-eval”, @manatabg93! I will pass along this feedback to our internal team for consideration. Perhaps we can create an SDK specific Browser Compatibility Table like the one linked below:

Also, feel free to share any suggestions on how we can best improve in this area. Thanks again for sharing your resolution and for developing on Zoom. We appreciate your contribution and look forward to supporting you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.