Unable to retrieve a webinar’s absentees - /past_webinars/{WebinarUUID}/absentees

Thanks @Ojus for the reply.

This is however confusing because with the same access token we are able to make calls to https://marketplace.zoom.us/docs/api-reference/zoom-api/webinars/webinarregistrants without any issue. Scope for that endpoint is also (webinar:read:admin webinar:read) .

If what you are saying is correct then requests to webinarregistrants should also not work, isn’t it?

Hey @nitin,

The https://marketplace.zoom.us/docs/api-reference/zoom-api/webinars/webinarregistrants endpoint works with two scopes as you can see in the docs, either webinar:read:admin (account level oauth) or webinar:read (user level oauth).

Thanks,
Tommy

@tommy @Ojus
I don’t see what is the difference in scopes of two endpoints, here are the screenshots for the two.

As you can see both the endpoint works on same scopes. Could you please help me with what am I missing?

Hey @nitin,

Can you send me your webinar uuid and I will investigate further?

Thanks,
Tommy

Hi @tommy

Webinar ID : ***********
Webinar UUID : LjPSI7uqQwqQwzCqhQB2oA==
USER ID : thqV5wx-TnaJSgCwctfUeQ

Please have a look and let me know.

*This post has been edited to remove any meeting / webinar IDs

Hey @nitin,

It seems you are using the wrong Webianr UUID.

Can you try this one: fd3xfXWbSZWfYB31jeytZg==

Thanks,
Tommy

@tommy I tried with the Webinar UUID as well, it doesn’t seems to work. Gave same issue

{
  "code": 200,
  "message": "No permission."
} 

Hey @nitin,

Can you please private message me your access_token so I can debug further?

Thanks,
Tommy

As requested i have sent you a PM, please have a look.

1 Like

Thanks @nitin,

I will reply to your private message.

-Tommy

Hey everyone,

We have fixed this bug on a release on June 7th.

Thanks,
Tommy

It’s still not working. I’m getting an “Invalid Access Token” error, but I know I have the correct access token.

Hey @steven.wadsworth,

Can you email your request url, headers, and access token you are using to developersupport@zoom.us so we can debug?

Thanks,
Tommy

I figured out the “Invalid access token” error. However, I’m getting a new message of “code”:3001,“message”:“Meeting does not exist: .” where is the UUID of my meetings I’m trying to sync. I’m using PL/SQL to double encode the UUID. So I’m not sure what the issue is.

Hey @steven.wadsworth,

What meeting UUID are you using?

Thanks,
Tommy

I have several. I’m looping through a number of meetings to get the absentees. Here is an example of some of the UUIDs –

  • GXHIFYd2Qfqx0Ry9q32e4g==

  • yVa10ePfS0ujuBqRmy9CUQ==

  • ryGWtrLaQxSTbiE+RTcrTw==

  • xT1HyyvhRriPaHKENZp1rw==

Hey @steven.wadsworth,

Those uuids are the pre meeting uuids. Once the meeting starts, they change, you can use the following methods to get the updated webinar or meeting uuids:

Webhooks:

Thanks,
Tommy

That worked! Thanks @tommy!

1 Like

You are welcome! :slight_smile:

Thanks,
Tommy