Unable to start meeting. Getting errors: "You cannot start the meeting (Meeting ID) because it is hosted by another user" and "If you are the meeting host, sign in to start the meeting (Meeting ID)"

Description
Short description: We have had two users who when trying to start the meeting have received the error “If you are the meeting host, sign in to start the meeting (Meeting ID)” or “You cannot start the meeting (Meeting ID) because it is hosted by another user”.

One user had the “You cannot start the meeting (Meeting ID) because it is hosted by another user” error on the day and time the meeting was due to start, but then a day later when it had finished when i used clicked the url it worked.

We have been using the API for 6 months and haven’t had issues until the last 2-3 days with these users. Nothing in the code for how we handle Zoom has changed. When we create a meeting, the start_url works, after a while it no longer recognises us as the host / logged in at all. But this seems to be random.

Long Description: After receiving these errors we began to look into the issue. Upon researching the situation we have found situations where we would schedule a class and the provided start url would work. Then we would wait a bit and it wouldnt work. Then we would come back and it would work, and then suddenly not work again. So the crux of the matter, without any reason at all Zoom does not recognise us as the host of the meeting sometimes and makes us sign in. Even for the same link this happens seemingly randomly.

Stuff we have confirmed:

- custCreate: All of our users, including the ones we used when testing are custCreate users so the start url should last for 90 days. We do not think it is an expiry issue.

- API: Running the get meeting API which returns a new start_url allows us to start the class. But the start url returned by the create_meeting API does not.

- Browser cache: Can confirm not cache related. Happens in all browsers and in incognito mode.

- Timezones: timezones are set correctly and confirmed not to be an issue (such as meetings scheduled for a different time and people technically joining the class late)

- Start time: Happens to meetings in the future, meetings in the past. Randomly. MOST of our meetings in the past are fine and work. MOST of our meetings in the future are fine and work too. There does not seem to be a connection as to why this is happening.

- End time: Some meetings randomly have an end_time or dont have an end_time. Even if they have already finished. This does not seem to relate to the issue we are having though as it occurs on meetings with and without end_time in the payload.

We can find no logical consistency for what is causing the start_urls to work or not work through our testing. It seems to be random.

Here is a payload we tested:

    `{'id': '95617216864',
 'type': 2,
 'uuid': 'yA0ktza4T/uJy43+XueldA==',
 'topic': 'Krasi testing stream',
 'status': 'waiting',
 'host_id': 'f5o-pA9zTPWz0EqA1Tf17g',
 'duration': 60,
 'join_url': 'https://zoom.us/j/95617216864?pwd=SGNtUHBGWXBtWXdmSEJJU3l2cHpzZz09',
 'password': 'F3ssoRiP8l',
 'settings': {'audio': 'voip',
  'use_pmi': False,
  'watermark': False,
  'cn_meeting': False,
  'host_video': True,
  'in_meeting': False,
  'contact_name': 'contact name here',
  'waiting_room': False,
  'approval_type': 2,
  'contact_email': 'email address here',
  'enforce_login': False,
  'auto_recording': 'none',
  'encryption_type': 'enhanced_encryption',
  'mute_upon_entry': True,
  'join_before_host': True,
  'alternative_hosts': '',
  'participant_video': False,
  'show_share_button': True,
  'close_registration': False,
  'enforce_login_domains': '',
  'allow_multiple_devices': True,
  'meeting_authentication': False,
  'registrants_confirmation_email': True,
  'registrants_email_notification': False,
  'request_permission_to_unmute_participants': False},
 'timezone': 'Europe/Sofia',
 'start_url': 'https://zoom.us/s/95617216864?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJmNW8tcEE5elRQV3owRXFBMVRmMTdnIiwiaXNzIjoid2ViIiwic3R5IjoxLCJ3Y2QiOiJhdzEiLCJjbHQiOjAsInN0ayI6IjA2WHVwT0NfM0hUZkhSdjNwdWpsM1Q1LTl6UXoxQzBBQWMxWG1RRV9LQjguQUcuMGxXYkx6cWxWS2dsaXpheF9jYUtEbzkybHNvUHUzVm01OUt2a2IzMG1FUk5YNm9yNlBMYTcxSzM3TEhqbnhPU3IxMlREeW42NkQtbFIyTS5KMkFkak12T3liYjZVMGxRT3pPeFdBLklQVmhfQU5WVUx0NlFVTDUiLCJleHAiOjE2MDQ2NTkzMTMsImlhdCI6MTYwNDY1MjExMywiYWlkIjoiN19NeGhBUHdRZGFUV3BpOVJPTzR4USIsImNpZCI6IiJ9.84ha0m-m--SfQrE_CB99yGz8RGi75IBs0qfx1EgKUIw',
 'created_at': '2020-11-06T08:41:53Z',
 'host_email': 'email address here',
 'start_time': '2020-11-06T13:00:00Z',
 'h323_password': '8281103215',
 'pstn_password': '8281103215',
 'encrypted_password': 'SGNtUHBGWXBtWXdmSEJJU3l2cHpzZz09'}`

Error
“If you are the meeting host, sign in to start the meeting (Meeting ID)” or “You cannot start the meeting (Meeting ID) because it is hosted by another user”.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT App

Which Endpoint/s?
Using https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate and https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meeting

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Not able to see a logical way to reproduce this. But it only took an hour or two of investigating to have the error happen to us. But there is no logical reason to it.

1 Like

Hi @dominic1,

Thanks for sharing these details and for outlining the issue you’re running into.

As a first step, just to rule things out—can I kindly ask you to confirm that you’re only trying to start these meetings under users within your account? Also, when you’re running into this issue, is it possible that anyone else may have clicked on the start_url or joined the meeting as a host beforehand?

Most commonly, these are the actions that can cause this behavior. But let me know—happy to keep investigating.

Thanks,
Will

Hi Will,

That’s correct. When accessing the start_url we are either logged out (as the start_url with the key as part of it acts as a way of logging in) or logged in using the correct zoom admin account. But we tested and tried to get to the bottom of this for 7 hours and we definitely tested this both logged in and not logged in.

Nobody else has access to the start_url. It’s only given to the person who should start the call.

To further confirm this, over the weekend we had 4 more times this has happened and again, nobody had clicked through to it at all. One user has had this issue 3 times now with 3 different meetings and the start_urls.

Hi @dominic1,

Thanks for confirming—We’re looking into this. Do you have any other examples of this you can share? If it’s possible to share those start URLs with me, that would be really helpful.

Thanks,
Will

Sure, but can i send it in a private message so other people on the forum don’t see it? Dont want random people on the forum clicking on these urls

Hey @dominic1,

Apologies—please see my DM. :slight_smile:

Thanks,
Will

Hello,

We are having this exact same issue and have a very similar configuration to @dominic1 and wondering if any cause/solution has been found.

Best,

Hey @chris.russo,

We’re looking into this (ZOOM-214739). For now, if you run into this issue with a start_url, fetching a refreshed start_url one via the GET Meeting API should resolve the issue.

Thanks,
Will

In case it helps, we too have been hit with this issue. We had understood that start URLs should be valid for 90 days for our custCreate API users but suddenly approximately one week ago they started becoming invalid much earlier. We found that start URLs retrieved even hours before would be invalid and so have moved to getting new start URLs for every request.

Hey @flippyhead,

Thanks for sharing, and good suggestion. This is our recommendation in the meantime, while our team actively works on a fix for this bug. (ZOOM-214739)

Thanks,
Will

Has there been any update to this issue? My team and I have also been experiencing this.

Is there a way to check that support ticket ID?

Thanks

Hey @Ajezior,

We expect a fix for this to be released very shortly. The ID listed here is internal only.

Thanks,
Will

Hello, we are having the same problem. Our work has also started to be a problem. Could you please get back as soon as possible?

Hi @gamebooker,

This original issue in this thread should have been resolved. If you’re seeing this message, can you ensure that you don’t have join_before_host disabled? If you want to share an example Meeting ID, I’m happy to help take a closer look.

Thanks,
Will