Undefined symbols for architecture arm64


I am using zoom mobile iOS sdk and it is working fine in my xcode, also i am able to create ipa successfully.

But when i try to create ipa using github Actions (CI/CD) i am getting the below error.

I tried with mobile only sdk as well as with both (Mobile & simulator) supported sdk but not get success and getting the same error.

It is showing the arm64 arch error in MobileRTC, _MobileRTCActiveVideoView class.

Undefined symbols for architecture arm64
> Symbol: OBJC_CLASS$_MobileRTCActiveVideoView
> Referenced from: objc-class-ref in VideoViewController.o

ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Error: Process completed with exit code 65.

Please look into the screenshot for error:

Hi Team,

As i observer i found that i am getting this warning also.

MobileRTC.framework/MobileRTC, building for iOS-arm64 but attempting to link with file built for unknown-unsupported file format ( 0x76 0x65 0x72 0x73 0x69 0x6F 0x6E 0x20 0x68 0x74 0x74 0x70 0x73 0x3A 0x2F 0x2F )

Hey @yadav.rajat

Its good to see you again! :slight_smile:

Can you remind me what version of the SDK you are using?

Usually, when this happens, the framework is set to “Do not embed” which it should be set to “Embed and sign”. It is also possible the path for the framework is incorrect.

I noticed there is an error saying your deployment target is set to 4.3. Could that be causing the issue?