User settings updated webhook doesn't fire when recording settings changed

Description
When a user visits: https://zoom.us/profile/setting?tab=recording
When switching toggler of Automatic recording or any other settings. I don’t receive a webhook of “user.settings_updated”.

App id: [REDACTED]

Error
Webhook for “user.settings_updated” not received for any changes on the recording tab.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Using OAuth and Webhooks.

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Visit https://zoom.us/profile/setting?tab=recording
  2. Toggle "Auto recording”

Hey @maksim.shitsko,

Thank you for reaching out to the Zoom Developer Forum. Just to make sure that I understand, are you able to receive webhook events when you change other settings on that page.

Only the Auto Recording setting has this issue, correct?

Thanks,
Max

Hello, Thanks for your reply!

Auto Recording is the one I actually need. I tried a few other settings on the recording tab (not all), and didn’t receive webhooks too.

But I receive user.settings_updated webhook when I change “meeting authentication settings”. And this is the only setting that worked for me. I tried some on the Conference tab.

Hey @maksim.shitsko,

Thank you for the update. I was able to reproduce this issue on my end and have since reached out to our engineering team for confirmation.

I’ll be sure to update you here when I have more information. (ZOOM-264386)

Thanks,
Max