Webhook not received when changed auto_recording from "local" to "cloud"

Description
When a user visits : https://zoom.us/profile/setting?tab=recording
Under the section “Automatic recording” , User can select “local” or “cloud”
Even if the App is registered for webhook “user.settings_updated” event, webhook is not received in above case.

But, If “Automatic recording” itself is turned OFF or ON then, I do receive the Webhook with event “user.settings_updated”.

Error
Webhook for “user.settings_updated” not received for that change only.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Using OAuth and Webhooks.

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Visit https://zoom.us/profile/setting?tab=recording
  2. Toggle “Record in the cloud” to “Record on the local computer” or vice versa

Hey @devendra_zoom,

Is this the app in question: https://marketplace.zoom.us/apps/WObcbW-FQLqd0wSHoI3oNg ?

Thanks,
Tommy

Hi @tommy, thanks for taking a look. Yes that is the app.

1 Like

Hey @devendra_zoom,

We are looking into the issue and will get back to you. (ZOOM-139931)

Thanks,
Tommy

Thanks @tommy
While that App is in the question, It is our production app. Before making final changes I am testing on the app “Avoma User Level INT app”. I have registered webhooks for our test app “Avoma User Level INT app”. But finally I will need the same thing in our prod app “Avoma Meeting Assistant”

Is it safe to share client ID of the test app here? I can share that of the test app if needed. Let me know.
I hope it helps debugging.

1 Like

Hey @devendra_zoom,

Yes it is safe to share client_id’s as they are public and can be found in the install URL.

Although since you share the app name, that is enough for us to look at the logs. :slight_smile:

Thanks,
Tommy