Video is not working in Chrome 94

Description
When a participant tries to join a video meeting, he is not able to see his own video and fails to send the video to the other participants. This is only happening in Chrome browser (Version 94.0.4606.61 (Official Build) (64-bit) and Version 94.0.4606.71 (Official Build) (64-bit)). It works perfectly fine in chrome browser (Version 93.0.4577.63 (Official Build) (64-bit)) and in Firefox (version 92.0.1) on any operating system.

Browser Console Error

TypeError: Failed to execute 'copyTo' on 'VideoFrame': rect.y 5 is not sample-aligned in plane 1.
    at efddc9e7-efce-474d-8104-c5e1dda922f7:1
    at I (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
    at Generator._invoke (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
    at Generator.e.<computed> [as next] (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
          at n (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
          at s (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
          at efddc9e7-efce-474d-8104-c5e1dda922f7:1
          at new Promise (<anonymous>)
          at new t (efddc9e7-efce-474d-8104-c5e1dda922f7:1)
          at efddc9e7-efce-474d-8104-c5e1dda922f7:1

Which Web Video SDK version?
SDK version : 1.1.5

Video SDK Code Snippets

const initRes = await this.client.init('en-US', 'Global');
// signature is generated by our server
const joinRes = await this.client.join(meetingID, signature, userName);

Device (please complete the following information):

  • OS: macOS Version 11.5.1, Ubuntu 20.04, Windows 10
  • Browser: Chrome
  • Browser Version : Version 94.0.4606.61 (Official Build) (64-bit) and Version 94.0.4606.71 (Official Build) (64-bit)

Additional context
We have completed the following things

  1. Followed all the steps in https://marketplace.zoom.us/docs/guides/stay-up-to-date/announcements#web-isolation.
  2. Applied SharedArrayBuffers origin trials for our domain. This temporary extension works until the Chrome 94 release.
  3. We have also patched video sdk version 1.1.5 dist files as per the release notes at Web Video SDK 1.1.5 Dependency Work Around
1 Like

Hey @mitesh.gandhi ,

Instead of 'Global' can you try using 'https://source.zoom.us/videosdk/1.1.5/lib' . That should fix the issue! :slight_smile:

-Tommy

Hey Tommy,
We replaced ‘Global’ with ‘https://source.zoom.us/videosdk/1.1.5/lib’, but we are still getting the same error “Failed to execute ‘copyTo’ on ‘VideoFrame’: rect.y 5 is not sample-aligned in plane 1.”

Thanks,
Mitesh

@tommy fwiw when I click that link for ‘https://source.zoom.us/videosdk/1.1.5/lib’ I get an 403 error response (AccessDenied).

Hey @mitesh.gandhi ,

Can I ask for steps to reproduce this issue? It seems like this could be an issue with how you are rendering the video stream.

I cannot reproduce this error with our sample app: GitHub - zoom/sample-app-videosdk: zoom videosdk web demo

Thanks,
Tommy

Hey @victor.aprea ,

That is correct. You need to pass in that url like I mentioned above, and the SDK will grab the public assets itself. :slight_smile:

-Tommy

Hey Tommy,
The issue is fixed. The error was due to configurationOptions (width and height) being passed as a parameter to the method stream.startVideo.

captureOptions = {
    captureWidth: this.config.width,
    captureHeight: this.config.height
  };
await stream.startVideo(captureOptions)
// changing to below code fixed it
await stream.startVideo()

Thanks for your help.
Mitesh Gandhi

Happy to hear you got it sorted out! :slight_smile:

Please let us know if you need anything else.

-Tommy