Web client SDK my video is blank in chrome or edge, but is working in firefox

I made a zoom meeting with 2 web sdk clients.
Client 1 activated the video.
Client 2 not and for him the video of Client 1 is displayed
Client 1 has a small window to see his own video, but this is only black. No video is displayed.

Client 1 used Chrome Version 92.0.4515.107 (Offizieller Build) (64-Bit)
Client 2 used Edge Version 92.0.902.55 (Offizielles Build) (64-Bit)

I repeated the test by switching the CLients.
Same issue.

Then I used for Client 1 the Firefox browser (90.0.2 (64-Bit)).
For FF the own video was displayed.

My video is not displayed in the small video window when I have activated the video for Chrome and Edge.

Which Web Client SDK version?

To Reproduce(If applicable)
Use chrome and Edge with webclient and start video with the client.

Chrome: (video started, blank own video)
Edge: (video started, blank own video)

Firefox: (video started, own video is displayed)

Device (please complete the following information):

  • Device: PC
  • OS: Windows 10
  • Browser: Chrome, Edge, Firefox
  • Browser Versions:
    • Chrome 92.0.4515.107 (Offizieller Build) (64-Bit)
    • Edge 92.0.902.55 (Offizielles Build) (64-Bit)
    • Firefox 90.0.2 (64-Bit)

We are also seeing this issue in Chrome and Edge - but working on Firefox. Currently on version 1.9.6 of the Web SDK.

Edit: I see another thread with more information on this: Getting Blank screen on self Video

Thank you for the link.
I have added the headers but it did fix the probel :frowning: .
I added the following headers to my app:

  • Cross-Origin-Resource-Policy: cross-origin
  • Cross-Origin-Opener-Policy: same-origin-allow-popups
  • Cross-Origin-Embedder-Policy: require-corp

The zoom meeting has been init with:

  • disableCORP: true or false
    No setting worked …

Maybe I did something wrong or is still missing :slight_smile:

I have activated the video preview and there the video is working:

After I joined the meeting, it is not working anymore :frowning:

But in ff this works:

I have also tested without the iframe and it didn’t work :frowning: .
I have also tried to use the av files from “https://source.zoom.us/1.9.7/lib” instead from my own server but didn’t change anything.
The debug output does not provide any helpful information :smiley:

Any ideas what I can do?

Hey @mariopulker,

Thank you for reaching out to the Zoom Developer Forum. Please try enabling the WebCodecs and SIMD origin Trials in Chrome. This should allow the most efficient APIs to be used.


Hi Max.

Thank you for your support.
The my video and gallery view is now working in chrome.


Hi! I have that very same problem, but the solution given did not solved it for me.
I have a cross origin isolated website, with both the origin trials applyed, but still the user cannot see itself on camera after joining the meeting.

Hi Ten_Meetings.

I also activated the Shared Array Buffer trial:
SharedArrayBuffers in non-isolated pages on Desktop platforms

Direct link to the shared array buffer trial:


1 Like

Hello here.
Im using Zoom sdk.
I got token from Origin Trials

but then what should I do next?
Please teach me how to enable self-video-screen. its black now…

Im from Japan, sorry my bad English.

Hello Team ,
I am using web sdk 1.9.5 with angular 8 i get the same issue
i register for origin-trials
adding token in meta tag in index page i still can’t see my self
any help
@MaxM @tommy

@Ten_Meetings Please try enabling the SharedArrayBuffer Trial if you can’t enable Web Isolation

@yusuke09072011 Please use the following guide to add a meta tag to the head of your html document:

@desouky Please try testing with the latest version of the Web SDK

I have enabled SharedArrayBuffer Trial, my site is crossOriginIsolated, I have all those OriginTrials applied as well. My SDK is up to date, still not showing the user’s video is not working. Any ideas?

Hey @Ten_Meetings,

Please send an email to developersupport@zoom.us with a link to this thread. I’m tracking a similar issue right now and would like to have a ticket to investigate further.

If I don’t have an answer for you shortly we can set up a meeting to debug live.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.