Waiting Room Disabling Not Working

Hello there,
I am using the zoom API: https://zoom.us/oauth/token?grant_type=account_credentials&account_id=
with the body:
topic: ${host.name} will join you shortly,
type: 1,
password: meetingPassword,
duration: 90,
settings: {
waiting_room: false,
join_before_host: true,
approval_type: 1,
auto_recording: ‘none’,
meeting_authentication: false,
//host_video: false,
participant_video: true,
authentication_exception: [
name: host.name,
email: host.email,
name: guest.name,
email: guest.email,

As you can see I have allowed join before host and disabled waiting room, however when entering using the join URL after entering password, I am directed to the waiting room.
I have noticed that in the response I am getting join_before_host: false despite setting it to true both in the request body and my account settings

Hi @nora.bierak
Thanks for reaching out to the Zoom Developer Forum and welcome to our community.
For this specific reason, make sure to enable the “Allow participants to join before host” in your account setting in able to have this applied to your meetings.

To do so, you want to log in to Zoom and go to your Admin Tab > Account Management > Account Settings > “Allow participants to join before host”

Hope this helps,

1 Like

But in my case i do not want them to open the meeting on their own, i want them to enter the room after the host has entered the room with out waiting if anyone is joining after the host has opened and started the meeting

@anupam In that case you can disable the feature allow participant to join before host and disable waiting room so participants will only be able to join once the host has started the meeting