Webhook Meeting ParticipantLeft request body empty (only in JWT app)?

My MeetingParticipantLeft webhook endpoints don’t seem to be getting anything if I have them set up in a JWT app, but they do work in a webhook-only app. Set up the exact same way as the PartcipantJoined, which is working fine.

I couldn’t get into the endpoint with signature of:
MeetingParticipantLeft([FromBody] ParticpantJoinedLeftModel model)

So I figured my model had some parsing issues, changed it to:
MeetingParticipantLeft([FromBody] string model)

and it gets in, but the string is null/empty.

If I change it to
MeetingParticipantLeft(string model)
…I don’t get in again, so I’m assuming RequestBody/FromBody is correct (especially since ParticipantJoined works fine)

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT app. **just learned that if we do it from a webhook-only app this works. wth?

Which Endpoint/s?
webhook MeetingParticipantLeft calling my c# webapi endpoint

I mean I guess the answer is just to create a webhook-only app for this, but why does /Joined work from a JWT app but /Left does not?


Hi @Allen-D,

Thank you for writing us, I am happy to help. The request body should be there, can you confirm that your endpoint URL is being hit. If so, you verify that you are logging the response body correct. Here’s a related stack overflow post for logging the request body in C#:

Also, can you verify that you are not using the same endpoint for both apps. If you are using the same endpoints for both app, the first app the endpoint was used for will send the webhook.


Hi Donte, I guess it’s more of a “why was it like this” question since we just created a new WebToken app and it worked fine.
The entirety of our zoom marketplace setup at the time I wrote was:
1x JWT app that we also subscribed to webhook events with. ParticipantJoined worked fine, ParticipantLeft did not, couldn’t get anything at all to pick it up.

Someone said “let’s try creating a webhook-only app,” did that…and it started working fine from there, no changes/same config/etc.

So now we have the JWT app that we use to make api.zoomgov.com calls to, and then we have a webhook-only app that sends us notifications. I guess it’s not a problem? Just seemed weird that the one subscription was fine but not a different event subscription.

Hi @Allen-D,

Thank you for your question and for providing that additional information. Please send an email to developersupport@zoom.us with a link to this thread. In that email, please include your account information and list the events that are missing.

We’ll investigate the issue further from there.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.