Webhooks: not receiving meeting.participant_joined while receiving other events

I’m trying to use the meeting.participant_joined and meeting.participant_left webhooks to count how many people are in a meeting.
During testing I receive the meeting.participant_left webhook reliably but through the exact same url, I do not receive the meeting.participant_joined webhook.
I have received the webhooks when I last used it about 2 months ago.

There is no error message.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
account-level JWT using the Webhooks

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. set up meetings for different API users
  2. join a meeting and don’t receive joined webhook
  3. leave meeting but receive left webhook

Screenshots (If applicable)
Not applicable

Additional context
I have many meetings set up on different users on the same account (all of them are licensed).
I have set up an account-level app using JWT. I have used this same app about two months prior, where it worked (except for minor issues with unknown cause).
The meetings are on API-only users.
The require registration and the participants are automatically registered through the API when they go to the spot in our application.
The meetings are in the future from now but have join before host activated. (I tried setting the time so it’s currently running but the result was the same)
There is only one webhook URL set and I set it to log whatever it gets. I get events like meeting.participant_left or meeting.registration_created for example, but no meeting.participant_joined.

Additional question: If I go to the logs of my Zoom app, I can see call logs but not webhook logs. Is there any way I could see the webhook logs there as well? That would be a great help with debugging.

Hi @fn.eventclass ,

Just to confirm – when it worked in the past, you received the webhook when participants joined a scheduled meeting before a host?


Yes, that is correct. Join before host was activated and the host was an API-user, that couldn’t join the meeting anyway.
I remember sometimes having trouble during testing back then but most of the time it worked. But now I don’t get “joined” events at all but “left” events reliably.

Hi @fn.eventclass ,

Thank you for this info. I’m going to check internally to see if something has changed with our webhooks and if I can reproduce this through testing.


Hi @gianni.zoom,

Any updates on this issue? I am seeing the same thing.

Also, 2x on seeing the webhook logs.

Thank you

Hi @ahavatammi , no there wasn’t a mass change to our webhooks. Can you please submit a support request with your webhook information and app credentials?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.