Webinar issue that happens randomly, buttons disabled and users do not appear in participants list

When joining a webinar, sometimes the QA & Raise hand buttons are disabled and cannot be clicked. Also, the attendee name doesn’t appear on the participants’ list but it’s counted.

No errors are displayed in the browser console

Buttons disabled, attendees do not appear in webinar’s list
Which Web Client SDK version?
1.9.6 & 1.9.7

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Join a Webinar
  2. Refresh or Leave multiple times

Loom video with the random behaviour. You can see that the attendee will briefly appear the participant’s list then disappear.

You can see the Zoom App having a list of attendees empty, but the attendee that joined from the WebSDK sent a message.

Device (please complete the following information):

  • Device: Desktop
  • OS: Windows 10
  • Browser:Chrome, Firefox
  • Browser Version: 92, 90.02

Additional context
It works well locally

1 Like

Same problem, version 1.9.5 and 1.9.7
What I noticed was that if you have any problems with the audio when entering the webinar, the desktop zoom counts the participant but he doesn’t appear in the participant list

When the error happens the console shows: XMPP Disconnected!, true

When someone joins successfully shows: POOL: memberChange,true

Hope this can help to find the root of the problem.

Is the problem because of SharedArrayBuffers?

No, we’ve enabled it and it’s still happening. Besides, we’ve tested on old Chrome versions too, and still the same.

The XMPP error doesn’t appear here, it still doesn’t work correctly
Updates the number of participants but does not list


1 Like

You have to enable the debug mode to see the logs I got from my previous images


      debug: true,

More updates on this:

It happens in older versions 1.8.6 1.9.0 etc, it also happens using the Zoom sample react app.

We found it only happens with webinars from our production license, if we use our dev/staging licenses we don’t see this error, so it may be some missing setting/configuration. We already updated settings to match both but it’s still happening.

Waiting for some official response from Zoom. This issue is quite critical to us as we use these functions extensively in our ISV program.

Version 1.8.6 using the sample react app:

As I said before it only happens with webinars we have on production. Since video, audio, shared screen still works it’s likely those WebSockets are still running. So the issue it’s related to the messaging(XMPP) as you can see in previous images.

The chat still works so either QA/Polls/ Raise hand makes the XMPP server/socket to be disconnected. Again, happens randomly, sometimes there are no issues:neutral_face:

I am also having this issue with our integration. Sometimes it works but most times it doesn’t. I don’t have any additional information to share except that I tried putting timeouts before calling ZoomMtg.init and ZoomMtg.join just in case things were not loading in time. That did not help though.

Hey @giancarlo1 , @WarrenB , @fernando.moobi ,

Thanks for sharing this, we are taking a look at this issue. (ZOOM-296649)


Hi @tommy, any update on this issue from development?

Hey @WarrenB,

This fix is slated for the end of this month when we release the latest version of the Web SDK.


1 Like


Just reporting that we have this same issue. It was working great on July 19-20 on a big event. Then this week we had a 4 days event using the Webinar SDK for 850 participants and over 75% of the participants were not being listed. We had to quickly turn around and use a large meeting, which isn’t great in our business.

Hey @Ntlum,

Thank you for sharing how this is impacting you. We were able to prioritize this issue and are working to resolve it as soon as possible.

In the meantime, please see our changelog in order to stay up-to-date with the latest features and fixes. You can also subscribe to the latest news at developers.zoom.us.


With the latest updates of the Video SDK Web v1.1.4, it appears to have fixed the issue. I have reconnected to the meeting many times and not experienced the issue once. Normally I would experience it 9 out of 10 times.


Thank you for the quick update on this Zoom devs! :smiling_face_with_three_hearts:


It’s been fixed. Thanks!


@giancarlo1 @WarrenB Awesome! I’m glad to hear this has been fixed.

I’ll go ahead and close this topic now but feel free to open a new topic if you encounter any further issues or questions.