"You cannot authorize" because of required permissions

I have been using a zoom oauth app for over a year now. Recently, I’m getting the error when trying to AUTH:

You cannot authorize **My app

You cannot install the app because you don’t have the required permissions. Please contact your IT administrator for permission and try again. Edit on Web Portal

I have looked at the permissions but all seem enabled for allowing users to authenticate it? It worked flawlessly in the past? What do I need to change?

I have both options enabled on : ADMIN APP MANAGEMENT in the App Marketplace.

Hello, @mick1 Do you mind sharing any more information about your app? I assume its an account-level app does it utilize any scopes like Sub-account management scopes or chat management scopes that can limit the user base because some of those permission can only be accessed by admins or Account Owners

Hi @kwaku.nyante , thanks for the response!

Its an account level OAUTH app, and yes a number of scopes require ‘admin’ approval. Here are my scopes:

The weird thing is this worked fine up until a few weeks ago?

@donte.zoom @gianni.zoom if you could please help here I tried most of what is in my repertoire and it didn’t work

Hi @mick1 since this is an app you have installed, can you please connect with your account owner/account administrator that authorizes marketplace app installs?

HI @gianni.zoom , I am the account owner for my account. Is that the issue? Solely on scopes?

Thanks for the prompt response by the way! This used to work fine, but just stopped in the last few weeks?

Hi @mick1 ahh you’re the owner and it’s not letting you install?

As the account owner, you should be able to install apps unless the app publisher has some sort of restriction. Please review this page and then if you copy the url from the error page you see.

In addition please share:

  • email address
  • account number or id in the private message I am starting with you

Access your private messages like so:

Screenshot 2024-03-18 at 10.49.54 AM

Hi @mick1 ,

This is being escalated internally. I created a ticket on your behalf (TS0912693). Please await updates.

This topic was automatically closed after 30 days. New replies are no longer allowed.