"Your connection has timed out and you cannot join the meeting" error with React quickstart

Description

I’m getting the Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again error when using the react sample app. It’s using SDK v1.9.0. I’ve followed the setup instructions, with the only deviation being to rename app.js to App.js because the file was incorrectly named out of the box.

I’ve already gone through the megathread about this error and addressed all of the potential errors I could find. I was directed to make a new topic about my specific problem.

  • I’m using a JWT App type for the key
  • My developer account is Pro
  • I’ve tried both starting a new meeting (with role == 1) and joining an existing meeting (with role == 0) with the same error both times
  • There is no issue with signature generation - my endpoint is live on Heroku and I’m able to successfully retrieve signatures with Postman. The signature generation server is using JWT app credentials.
  • I’ve been using an 11-digit number for the meeting number: 74781708845

How can I fix this error? Thank you!

Which Client Web SDK version?
1.9.0

Device:

  • Device: 2014 MacBook Pro
  • OS: Catalina 10.15.1
  • Browser: Brave 1.18.77 (shields down); also tried Safari 13.0.3

Hey @keaton ,

Can you please share the error message in the browser console? :slight_smile:

Can you explain this further? The sample app was generated via Create React App and I did not rename any generated file names.

Thanks,
Tommy

Hey @tommy thanks for the response! I actually was able to join a meeting from the sample app that I had started from a separate desktop client! I don’t know why I wasn’t able to the other day.

However, I can’t start a meeting from the sample app, even if I change the role to 1. The error in the console is:

errorCode: 3707
errorMessage: undefined
method: "join"
result: "The meeting number is not found."
status: false

Does this have to do with the method being 'join'? I didn’t see a start or similar function in the SDK docs, but is that what needs to change? Is starting a meeting from the web client possible?

Oh, the naming issue has to do with my getting confused because the README references app.js so I originally started to make one before I realized there was already an App.js :sweat_smile: I thought I remembered having to rename a file, but it looks correct in the repo, so I’m not sure what happened. It’s all good, just maybe update the README for clarity.

Hey @keaton,

Thank you for providing additional information.

You will use the join() function to join or start a meeting. The role is what indicates if you are trying to join or start the meeting.

Please make sure that the meeting you are attempting to start is hosted by a user on the account your JWT credentials are from. Please see the following document for more information:

I hope that helps! Let me know if you have any questions.

Thanks,
Max