Zoom GET /users endpoint not returning all users in account

Good evening, I’m an engineer working at Appointedd responsible for our Zoom integration. We currently have a OAuth Zoom Application which allows users to link Zoom users to Appointedd resources. We pull down the list of users to be linked via the GET /users endpoint to populate a dropdown list.

One of our clients is reporting users missing from this list and we’ve identified that the endpoint is not returning all of the users on their account. We’ve confirmed the missing users are “active” and that we’re not missing any pages of the paginated response. Pulling one of these users directly using the GET /users/{id} endpoint with their id from within Zoom returns the missing user with no issues, and we can’t see any clear reason why they wouldn’t be appearing in the main GET /users results. Are there any criteria for not appearing on this request that aren’t documented?

I have user id’s and account id’s available on request via DM.

GET /users endpoint returning incomplete data.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
GET /users

How To Reproduce (If applicable)
Unable to reproduce on our internal account however
Steps to reproduce the behavior:

  1. Have a multi-user Zoom account listing many users
  2. Make a call to the GET /users endpoint.
  3. Only recieve a subset of the users expected.


Thomas Kendrick
Software Engineer

Hi there. We’ve managed to identify the problem. The API documentation states that a page_number of 1 will be passed by default and our code wasn’t passing it explicitly, however were stating the page_number explicitly in subsequent requests (2+ etc).

It appears that not explicitly providing the page number results in a different sequence of results, leading to a mismatched set of records when combined. We presume this is due to your next_page_token implementation. We’re going to go ahead and migrate to using these tokens however looking for clarity if this was expected behaviour.


Hi @tkendrick,

Thanks for following up and confirming that you were able to get this working.

While we will be moving towards exclusively using the next_page_token, you’re correct in that you will want to explicitly pass the page_number parameter from your first request if there are multiple pages of results. We will work on making this clearer.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.