Zoom SDK translation

I’ve translated the SDK to Hebrew using SDK v4.4.55130.0712.
There is one string I wasn’t successful in translating, the string is: “To hear others please join audio”. What is the needed key?
Please see attached screen shot for reference:

Hi idit,

Thanks for the post. The key for the untanslated string shown in the screenshot is: “To hear others\n please join audio”, you can follow the instruction here to customize the string:https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/techniques/customize-language

I will also pass this information to our engineer team and working toward to translate it by default.


1 Like

Worked! Thanks a lot!

Thanks Carson!

Let us know if you have any other questions @idit.barash :slight_smile:


I asked also in another thread. I’m using version number: v4.4.55130.0712. Downloaded from https://github.com/zoom/zoom-sdk-ios (also tried from https://github.com/zoom/zoom-sdk-ios/releases).
I’m getting an error when uploading to TestFlight:
ERROR ITMS-90171: “Invalid Bundle Structure - The binary file ‘UnifiedApp.app/Frameworks/MobileRTC.framework/MobileRTC’ is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at https://developer.apple.com/go/?id=bundle-structure for information on the iOS app bundle structure.”
I followed all the instructions here:
Can you help @tommy ?

Hey @idit.barash,

Maybe this article can help?


Let me know if it works!


Hey @tommy,

I don’t have it in build phases, so it doesn’t help :frowning:


Hi @tommy

Regarding the error I got when uploading to the store, it seems to be an issue with our CI system. When uploading from my Mac it works.

Thanks anyway,

1 Like

Hi idit,

Thanks for the reply. Regarding the issue “Invalid Bundle Structure”, since we have another thread with more details here:Running Zoom SDK from an iOS Swift framework, shall we move over there and continue the troubleshooting on that thread. We will provide further assistance on this issue there.

Regarding the translation issue, is this problem resolved? Are there any other things that we can help?


Hi Carson,

The translation problem was resolved. We can close this thread. Thanks!

1 Like

Glad to hear @idit.barash!