Zoom WEB Meeting & Desktop client is not not sync correctly

I integrate Web Client SDK with my laravel web application. when user join to the meeting. my web application checked wheather user is autorized persoon or not .

So I developed that functionality . it is working !

    ZoomMtg.inMeetingServiceListener('onUserJoin', function (data) {
            console.log("ON USER JOIN");
            console.log('inMeetingServiceListener onUserJoin', data);

            var userId = data.userId;
            var userEmail = data.userName;
            var isHost = data.isHost;

            $.ajax({
                type: "GET",
                url: "{{ url('meeting/web/checkAuthorizedUser') }}/",
                data: {
                    'userEmail': userEmail,
                    '_token': '{{csrf_token()}}',
                },
                dataType: 'json',
                success: function (isAuthorizedUser) {
                   
                    if (!isAuthorizedUser) {
                        ZoomMtg.expel({
                            userId: userId
                        });
                    }
                }
            });


        });

Here is the problem.

  1. Student captured meeting ID & passcode via on URL
  2. Login in to the the Zoom Desktop Client & entered meeting ID and passcode
  3. Enter his personal email (it is not registered with my system)
  4. then my system rejected that request . that is OKAY . " ZoomMtg.expel" is working correctly .
  5. After that my student closed the Desktop Client and try to log into the meeting again with his authorized registered email .that should be accept by my application .because the student has authorized email .
  6. Unforuantely Zoom DESKTOP client will not allow for that . its failed.
    ss12
  7. After that , I go to zoom web admin panel and click “End the Meeting”
  8. I Started my meeting again & recheck the Desktop Client .
  9. then it works without having any issues.

Hey @digix.sameera,

By default Zoom doesn’t allow removed participants to rejoin the meeting, however you can change that in your account settings.

  1. Sign in to the Zoom web portal.
  2. In the navigation menu, click Settings .
  3. Click the Meeting tab.
  4. Under In-Meeting (Basic) , verify that Allow removed participants to rejoin is enabled.

Thanks,
Alex

@alexmayo is that possible to apply this settings via on API

Hi @digix.sameer

Currently this is not included within the users/usersettingsupdate endpoint, however you can request it in #feature-requests.

Thanks,
Alex

Thanks for helping @alexmayo! @digix.sameera Let us know if you still have questions.

Best,
Will

1 Like