ZoomMtg.init: The account don't enable API

Hi @Inkerz,

Did you try the recommendations that we suggested here?

Yes, I did try to use SDK credentials or API key/secret.
The App is JWT enabled.

However, I couldn’t find the developer privileges option in Zoom portal, could you point me out where to change that?

@Inkerz,

Within your Zoom portal under Role management -> Role Settings -> You’ll need to make sure Zoom for Developers are selected and have that members for your account have that as a role.

Thanks

I could not see this because Billing was not activated. It is now activated, and I put the Developers role to my account however, I still get the same error…

Hi @Inkerz,

We took a look at your account, looks like it’s a Free account. Currently, you will need a Pro account or a Free Trial account by contacting our support team to make sure your account is enabled to use the API Key/Secret.

Thanks

I have pro account and JWT is also enabled , we are using JWT API key and secret key .

Zoom for developers also enabled.

but still getting same error , can any one help on this?

Hey @thulasi.sri0,

Just replied to your post here:

Thanks,
Tommy

i have same issue :
status":false,“errorCode”:200,“errorMessage”:"The account don’t enable API.

Hey @rendyerasoft,

Looks like you have a free basic account. You will need to upgrade to at least Pro, or request a free trial here: isv@zoom.us.

Thanks,
Tommy

“…8. The only thing I changed is the API_KEY and API_SECRET but I get following response:…”

i have pro account…
and i already solved the issue, i need to add email and password input in index file

thank you for your respons

hi Tommy, are zoom have method or endpoint for end the meeting?.. both for mobile sdk and web sdk.

and can you give me info …how to disable meeting number and invite button ?

thank you Tommy

Hey @rendyerasoft,

You can end the meeting via the Update Meeting Status API endpoint or this function in the Web SDK.

To disable invite button, use this Web SDK function.

Thanks,
Tommy

oh ok tommy thank you

1 Like

You are welcome! :slight_smile:

-Tommy

Hi

I have same issue. I’m using JWT and SDK account type

  1. /**/localJsonpCallback({status: false, errorCode: 200, errorMessage: “The account don’t enable API.”, result: null});

  2. status: false

  3. errorCode: 200

  4. errorMessage: “The account don’t enable API.”

  5. result: null

I created JWT and SDK account type app in my account. I’m using the example provided on github (https://github.com/zoom/sample-app-web) and trying to connect to a meeting. But showing same error . how can i solve it ?

Using this sample app V1 api is forming. i don’t know that is a problem or not

Hey @manishkumarmm93, thanks for posting and using Zoom!

This error means you do not have a pro account. You need to have at least a pro account to use the Web SDK.

Thanks,
Tommy

@tommy Thanks for your replay .
I’m now using basic account . but, currently i can join the meeting. ok thanks

I have one more queries . how can i start/host meeting ? I’m using JWT account type.

Hey @manishkumarmm93,

Just change the role to 1.

Thanks,
Tommy