ZR-CSAPI - starting PMI meeting

Description
I’m using ZR-CSAPI for automating Zoom Rooms software. I’d like to start a PMI meeting. However, when I send the command zcommand dial startpmi duration:0 (for example) I get a response with meeting ID which changes every time.

Error
Here are the responses (partially):

zcommand dial startpmi duration:0
OK
*r DialStartPmiResult (status=OK):
** end

*s Call Status: CONNECTING_MEETING
** end

*e NeedWaitForHost Wait: off
** end

*s Call Status: IN_MEETING
** end

*e SpotlightStatusNotification user_id: -1
*e SpotlightStatusNotification present: off

*r InfoResult Info real_meeting_id: cwfNgsYhTLOvA3AfxUnG2A==
*r InfoResult Info meeting_id: 91642391571
*r InfoResult Info participant_id: 145255
*r InfoResult Info my_userid: 16778240
*r InfoResult Info am_i_original_host: on
*r InfoResult Info is_webinar: off
*r InfoResult Info is_view_only: off
*r InfoResult Info meeting_type: NORMAL
*r InfoResult Info meeting_password: 578320
...

and

zcommand dial startpmi duration:0
OK
*r DialStartPmiResult (status=OK):
** end

*s Call Status: CONNECTING_MEETING
** end

*e NeedWaitForHost Wait: off
** end

*s Call Status: IN_MEETING
** end

*e SpotlightStatusNotification user_id: -1
*e SpotlightStatusNotification present: off

*r InfoResult Info real_meeting_id: u0UDVUkOS+ek9kMfEOE+Ow==
*r InfoResult Info meeting_id: 97714566290
*r InfoResult Info participant_id: 139507
*r InfoResult Info my_userid: 16778240
*r InfoResult Info am_i_original_host: on
*r InfoResult Info is_webinar: off
*r InfoResult Info is_view_only: off
*r InfoResult Info meeting_type: NORMAL
*r InfoResult Info meeting_password: 772643

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Send a command zcommand dial startpmi duration:0
  2. Notice meeting ID in the response. It isn’t equal to room PMI number, by the way.
  3. Send a command zcommand call disconnect to end the meeting
  4. Repeat steps 1-3 again. Notice that meeting ID has changed.

Is it a bug or everything’s working as intended?

Hey @alexander.zarubkin,

This could be intended. Is the PMI the Zoom Rooms PMI or a users PMI?

Thanks,
Tommy

Zoom Rooms PMI, I think.

Hey @alexander.zarubkin,

Can you try using a number greater than 0? Also, what meeting number shows up on the scheduling display? Is that number different from the PMI still, or the same?

Thanks,
Tommy

It’s the same behaviour with duration:30: the meeting number always changes. I will check scheduling display later.

Hi @tommy, I could not start Zoom Rooms controller application on my phone in scheduling display mode. I use Android, I clear the application data, then restart it, log into the system, and it starts in room controller mode. There is no dialog to choose scheduling display mode.

I think I’ve solved my problem by turning on the option “Use Room Meeting ID when starting an instant meeting” (in the Zoom Room settings, Schedule meeting section).

Now zcommand dial startpmi uses PMI which is specified in the room settings. By the way, zcommand invite now uses PMI for the meeting ID too.

1 Like

Happy to hear you got it sorted out! :slight_smile:

Thanks for sharing the solution!

-Tommy