About Showing Partictipants room

I want to show the waiting room (participants), but I have faced some issues with it.

  1. First I want to know can I disable showing this alert, since we want to force to use internet audio, and we are using iPad there are no other chosen, and this alert will affect some of my function, I have a alertView show when entering the meet but since this alertView exists, my own one was blocked.

  2. I want to know whether can I call this alertView? If I cant, any suggestion (which class should call, workflow …) for me to do the same things (A alertview while the user in and with “see waiting room” and "admit’ function)

  3. I also want this too, it shows while clicking the “see waiting room” in the alertview on the last image. However, when I call the presentParticipantViewController it shows something similar but not actually what I want. It cant dismiss and exit and no cancel button, so whenever I call it, it holds on the top view, and the user cant does further action. It will be nice if there is some method to dismiss it.

The version of the Zoom SDK is v4.6.21666.0428, it isn’t the newest version since we might use it on the devices in which the iOS system from 10.3 to 12.1.


  • Device: iPadAir 2, iPad mini 3 ( We are develop for iPad use)
  • OS: iOS10.3,iOS, 11.1, iOS 12.0

We are using Xcode 11.1 to develop and we use Objective-C as our programming language.

The image for 2

Image for 3

Hi @lemon97213,

Thanks for the post. Regarding your questions:

If you would like to use VoIP as default, you could use MobileRTCMeetingSettings.setAutoConnectInternetAudio(Thanks for the post. It seems like you are facing issues with our Zoom client, which is out of the scope of what this forum is for(This forum is for Marketplace Apps). Please provide feedback to Feedback - Zoom or try to contact Zoom client support at https://support.zoom.us/hc/en-us/requests/new and one of the Zoom experts will be happy to assist you. ) to do that. Call this interface before starting/joining a meeting.

Based on the screenshot, it seems like you are using the Zoom default UI. This alertView cannot be disabled or customized at the moment.

The presentParticipantViewController is for Custom UI mode so it looks different and it requires additional implementation for the actions. When you press “See waiting room”, it actually shows up the participant list in the default UI.

Hope this helps. Thanks!

So can I customize the UI of the presentParticipantViewController ? If I can have additional implementation for it. Would you mind tell me where is the place to do the modification, I have suck in here for a week :frowning:

Hi @lemon97213,

Thanks for the reply. Calling the presentParticipantViewController will show up the Zoom default participant UI, which is not customizable. If you would like to customize the participant list, you will need to implement the participant list UI.

Hope this helps. Thanks!