Android - Video Not showing on Android 6 (API level 23) in meeting SDK v5.7.1.1267

Description
I am using default UI and can join or start meeting successfully while starting video it’s not visible to the other side and the other side video is also not visible, It is working fine in SDK version v5.5.1.1319 but it’s not working in v5.7.1.1267, and v5.7.1.1268. It seems to happen on all android 6 devices.

Which Android Meeting SDK version?
v5.7.1.1267

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Join a meeting
  2. Click on the start video
  3. See, The video view will not be visible to the user on another side and another side video also will not be visible to your side.

Smartphone (please complete the following information):

  • Device: Oppo F3 (CPH1609)
  • OS: Android 6 ( API level 23)

Hi @Sujeet, thanks for using our SDK.

I have been able to reproduce this behavior locally. We will need to investigate this and identify a fix. I will let you know as soon as we have any additional information. Apologies for any inconvenience caused by this behavior.

Thanks!

Hi @Sujeet,

Upon further investigation, I found that the behavior I was seeing was due to the camera permission not being requested until after I manually toggled the video off and the back on. Can you please verify whether or not your app has camera permission granted when you observe this?

If you do in fact have proper permissions granted, can you provide a full list of the devices you have been able to reproduce this issue on?

Thanks!

Hi @jon.lieblich ,

Thanks for your response
The camera permission was granted while testing still happening the same.

Samsung Galaxy J7
Vivo 1601
Oppo F3
CPH1609 (Oppo)
Vivo Y53

These are the device on which we are facing the issue and these are on android 6.

Thanks!

Hi @Sujeet,

Thanks for the additional information. Were there any devices on which this issue was not reproducible? Also, can you please provide the SDK logs so that we may investigate this further? It should be an encrypted file found at sdcard/Android/data/${YOUR_APP_NAME}/logs.

Thanks!

here is the
log file attachment

Hi @karpude.k, thanks for using the dev forum.

Can you and @Sujeet please confirm whether or not you are working on the same project together?

Thanks!

Projects are different.

Hi @jon.lieblich

Some More log files

Log file 2

Log file 3

Hi @karpude.k,

Thanks for confirming. Can you please let me know which version of the SDK you are using, the devices on which this issue is present, and the Android version being run on these devices?

Thanks!

Hi @jon.lieblich
Meeting SDK: 5.7.1.1268
Android Min SDK : 21
Following device tested and have same problem that is host’s or other participants Video and screen sharing not display (only black box shows)
Device 1: Samsung J1 - Android 4.4
Device 2: Samsung J7- Android 5.1
Device 3: Redmi mi 3s- Android 6.0.1
Device 4: Oppo F3 Android 6
Device 5: Vivo Y53 Android 6

Hi @karpude.k,

I am not able to access the first or third log provided. It appears that something went wrong with the file type of the first one, and I’m not seeing a log file in the third one. Can you please clarify which device was used for the logs provided in the second link?

Thanks!

@jon.lieblich
its Samsung J7- Android 5.1

Hi @karpude.k,

Thanks for that. We’ll investigate the logs you’ve provided and let you know as soon as we have any updates.

Thanks!

Hi @karpude.k,

It does not appear that the logs you have provided are valid SDK logs. Can you please obtain the SDK logs from the path mentioned here?

Thanks!