App submission form says ready to submit but Submit button never activates

Hi Zoom Team,

I’m trying to submit my app, but the Submit button doesn’t allow me to do so, even after the form says I’ve completed all the steps, and I’ve filled out all the required testing information and I’ve accepted the Marketplace agreement.s

See the attached screenshot.

I’ve tried Chrome, Firefox and Safari, so guessing it’s some data issue and unrelated to the browser

Hello @clippermadness

Can you check and make sure all domains are verified?

I have an email from the Zoom team that domains have been verified. We have to do that offline because there are multiple domains. Should be and

The Marketplace UI says that my domains are verified and I can submit, but like I say, the submit button is still not enabled.

Hello, @clippermadness I think because of the new additions to the UI some configuration things need to be resolved if you click on surface under features on the left-hand side of the submission page and fill in the details needed you should be good to go after that.

Regards, Kwaku

@kwaku.nyante Can do, but we don’t have a “surface”. Our app is an OAuth app designed to interact with data through the Zoom API, and does not have a UI that embeds inside of the Zoom client. I don’t see an option for “None” in. here. What should I do?

Also the Marketplace UI says “Ready for Submission” without me doing anything in the Surface tab.

@kwaku.nyante I’m happy to jump on a Zoom and debug in realtime if you’d like. DM me.

@clippermadness sent a DM

@kwaku.nyante Hello, we are having the same problem where the Submit button stays disabled even after filling out all of the forms. Request if you could assist further. Thanks!

@preetam please make sure you are using the App developers account for the submission. Collaborators do not have the ability to submit apps but they can add and remove items from the submission.

Regards, Kwaku

Ah, yes, that was it. Thank you!