Auto_recording to cloud not working as expected

Description
I have checked this post but it still show local

my request data was

{
“topic”: “Lesson 1 - 2020-06-13 - 17”,
“type”: 2,
“duration”: 30,
“password”: “”,
“start_time”: “2020-06-13T22:00:00+0200”,
“timezone”: “Africa/Cairo”,
“settings”: {
“host_video”: false,
“participant_video”: false,
“approval_type”: 0,
“auto_recording”: “cloud”,
“join_before_host”: true
}
}

The Answer was " local " , I tried type 1 for instant and 2 for schedual .

stdClass Object
(
[uuid] => AznsFxuITKeGRG441sc2hA==
[id] => ***********
[host_id] => sKRB-eZoS3q67o3vHWlcwQ
[topic] => Lesson 1 - 2020-06-13 - 17
[type] => 1
[status] => waiting
[timezone] => Africa/Cairo
[created_at] => 2020-06-13T03:28:04Z
[start_url] => xxxxx
[join_url] => xxxxx
[password] => 524560
[h323_password] => 524560
[pstn_password] => 524560
[encrypted_password] => TEFwODBYK21GYUZuSnN0dFNVZ3NyQT09
[settings] => stdClass Object
(
[host_video] =>
[participant_video] =>
[cn_meeting] =>
[in_meeting] =>
[join_before_host] =>
[mute_upon_entry] =>
[watermark] =>
[use_pmi] =>
[approval_type] => 2
[audio] => both
[auto_recording] => local
[enforce_login] =>
[enforce_login_domains] =>
[alternative_hosts] =>
[close_registration] =>
[registrants_confirmation_email] => 1
[waiting_room] => 1
[global_dial_in_countries] => Array
(
[0] => US
)

App Type
I’m using “JWT”

Endpoint/s?

https://api.zoom.us/v2/users/’.$user_id.’/meetings

Screenshots


How to set it cloud in main users and sub members too .

It only show cloud for main account users “Pro” but not sub members .

Best regards

*This post has been edited to remove any meeting / webinar IDs

Any Suggestions Please ?

Hey @momaiz.net,

Please try the following request body:

{
  "topic": "Lesson 1 - 2020-06-13 - 17",
  "type": 2,
  "duration": 30,
  "password": "",
  "start_time": "2020-06-13T22:00:00+0200",
  "timezone": "Africa/Cairo",
  "settings": {
    "host_video": false,
    "participant_video": false,
    "approval_type": 0,
    "auto_recording": "cloud",
    "join_before_host": true
  }
}

Thanks,
Tommy

@hello tommy ,
thank you for answer .

sorry it still not working .

Only work on Licensed member not with Basic members under Licensed account ,

does it require all members to be Licensed ?? and what’s requirements to set sub members as Licensed .

Best regards

Hey @momaiz.net,

Happy to help!

Are you creating the meeting for a user that has the Cloud Recording feature and is licensed?

Thanks,
Tommy

Hello @tommy .

Main Account Is Licensed as pro .

But i want to create meeting for sub account [ Basic Account ] under main account [ Pro licensed ] .

Best regards

Hey @momaiz.net,

The user who you want to set auto recording for, must be at least a Pro user:

Please see the prerequisites here:

Thanks,
Tommy